Forum: Rails deployment Trouble running my app

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Ed78a8e4ce036b46633e7385addea006?d=identicon&s=25 Matt (Guest)
on 2007-03-04 16:52
(Received via mailing list)
I tried posting this message earlier on the normal rails message board
and was advised to post it on here. Never knew this forum existed but
am glad to have found it.


Im having trouble running my app :(

I get the error message application error rails failed to start

So not being a total idiot(I may regret saying that) i checked the
logs and there was a problem in the server log only. It stated
premature end to headers for dispatch.cgi

I then tried to run the dispatch.cgi from a terminal expecting to see
error 500 but instead i get this:

matt@as public]# ./dispatch.cgi
Status: 400 Bad Request
dependencies.rb:405:in `to_constant_name': Anonymous modules have no
name to be referenced by (ArgumentError)
 from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/
active_support/dependencies.rb:215:in `qualified_name_for'
 from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/
active_support/dependencies.rb:477:in `const_missing'
 from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:117:in
 from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:51:in
 from ./dispatch.cgi:10

Which means nothing to me and google isn't bringing anything up :(

I have tried to reinstall rails and also updated gems and again no

Any clues at all would be most helpful, if you think more information
would help please ask me for it im not entirely sure where to start.

Im going to create a default app now and see how that goes. It may or
may not work i will post shortly.

Cheers in advance

Ed78a8e4ce036b46633e7385addea006?d=identicon&s=25 Matt (Guest)
on 2007-03-04 18:20
(Received via mailing list)
I have just created a new app on the server yet it doesn't work.

I can see the welcome aboard page then when i try to navigate to the
app say /public/admin i get no joy and it states the usual Application
failed to start message.

There is nothing in the server log either:( The development log looks
fine though which is odd no probs in there.

Any ideas?

To get rails started I followed this tutorial off media temple because
I have my server with them. (

Cheers in advance

38a02bf7121a81be5be6f3d488ce23b5?d=identicon&s=25 Alexey Verkhovsky (Guest)
on 2007-03-04 20:45
(Received via mailing list)
Beg pardon for asking, but is there a good reason why you use CGI, in
first place?

Ed78a8e4ce036b46633e7385addea006?d=identicon&s=25 Matt (Guest)
on 2007-03-05 10:28
(Received via mailing list)
Hey Alex thanks for replying,

Im sorry im a bit new to rails and was only following the tutorial on
Mediatemple who run my hosting.

What would you recommend I use?

Thanks again for helping

25395b2810e62945a8488357bfc56d0d?d=identicon&s=25 (Guest)
on 2007-03-05 16:04
(Received via mailing list)
Your tutorial is specific to your hosting provider.  Not sure there's
anything that will help you outside of media temple.

To learn rails get either get a copy of "Agile Web Development with
Rails" (

Or read this tutorial

I think folks are either user lighttpd or mongrel these days vs.

Ed78a8e4ce036b46633e7385addea006?d=identicon&s=25 Matt (Guest)
on 2007-03-05 16:14
(Received via mailing list)
Yeah thanks for the advice,

I have been working on getting mongrel installed and can get it
installed to work if I specify the port number in the address say the test app works. The app works fine.

However I am unable to get it working if i try to specify the domain
without the port say I think
the old apache way of running the app is taking presedence over the

I think im getting closer but not really sure any further light on the
matter would be very gratefully received.

Thanks again,

This topic is locked and can not be replied to.