Trouble running my app

I tried posting this message earlier on the normal rails message board
and was advised to post it on here. Never knew this forum existed but
am glad to have found it.

Anyways…

Im having trouble running my app :frowning:

I get the error message application error rails failed to start
properly.

So not being a total idiot(I may regret saying that) i checked the
logs and there was a problem in the server log only. It stated
premature end to headers for dispatch.cgi

I then tried to run the dispatch.cgi from a terminal expecting to see
error 500 but instead i get this:

[email protected] public]# ./dispatch.cgi
Status: 400 Bad Request
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/
dependencies.rb:405:in to_constant_name': Anonymous modules have no name to be referenced by (ArgumentError) from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/ active_support/dependencies.rb:215:inqualified_name_for’
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/
active_support/dependencies.rb:477:in const_missing' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:117:inreset_after_dispatch’
from /usr/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:51:in
`dispatch’
from ./dispatch.cgi:10

Which means nothing to me and google isn’t bringing anything up :frowning:

I have tried to reinstall rails and also updated gems and again no
luck:(

Any clues at all would be most helpful, if you think more information
would help please ask me for it im not entirely sure where to start.

Im going to create a default app now and see how that goes. It may or
may not work i will post shortly.

Cheers in advance

Matt

I have just created a new app on the server yet it doesn’t work.

I can see the welcome aboard page then when i try to navigate to the
app say /public/admin i get no joy and it states the usual Application
failed to start message.

There is nothing in the server log either:( The development log looks
fine though which is odd no probs in there.

Any ideas?

To get rails started I followed this tutorial off media temple because
I have my server with them. (http://kb.mediatemple.net/article.php?
id=128)

Cheers in advance

Matt

Beg pardon for asking, but is there a good reason why you use CGI, in
the
first place?

Alex

Hey Alex thanks for replying,

Im sorry im a bit new to rails and was only following the tutorial on
Mediatemple who run my hosting.

What would you recommend I use?

Thanks again for helping

Matt

Your tutorial is specific to your hosting provider. Not sure there’s
anything that will help you outside of media temple.

To learn rails get either get a copy of “Agile Web D. with
Rails” (http://www.pragmaticprogrammer.com/titles/rails/)

Or read this tutorial
http://www.onlamp.com/pub/a/onlamp/2005/01/20/rails.html

I think folks are either user lighttpd or mongrel these days vs.
fastcgi.

Jim

Yeah thanks for the advice,

I have been working on getting mongrel installed and can get it
installed to work if I specify the port number in the address say
www.ghmcc.co.uk/admin/ the test app works. The app works fine.

However I am unable to get it working if i try to specify the domain
without the port say www.ghmcc.co.uk/public/addresses/admin. I think
the old apache way of running the app is taking presedence over the
mongrel.

I think im getting closer but not really sure any further light on the
matter would be very gratefully received.

Thanks again,

Matthew

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs