Forum: Ruby on Rails Capistrano Help

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
8b22ad683842861ba91f68d5d32954db?d=identicon&s=25 Jason Norris (Guest)
on 2006-12-29 16:44
(Received via mailing list)
I'm trying to set up capistrano for one or more of my apps. I used it a
little bit successfully last week. Today I'm trying to set it up with a
real app. I did cap apply-to, then set up my deploy.rb.  When I do cap
setup, I get this:

[root]# cap setup
  * executing task setup
  * executing "mkdir ...."
    servers: ["web1", "database"]
  * establishing connection to gateway 11.11.11.11
    starting connection to gateway 11.11.11.11
Password:
    gateway connection established
    establishing connection to web1 via gateway
    establishing connection to database via gateway
Net::SSH::AuthenticationFailed

I get in to the gateway just fine, and all the passwords are the same.
But it keeps failing.
I even tried setting up SSH for no password, still with no luck. Anyone
have this problem before and/or know what may be happening?
Thanks
Jason
3299251223f55753ec84719de39e6e53?d=identicon&s=25 Jon Garvin (Guest)
on 2006-12-29 17:22
(Received via mailing list)
You'll probably get more helpful responses in the Capistrano list.

http://groups.google.com/group/capistrano
8b22ad683842861ba91f68d5d32954db?d=identicon&s=25 Jason Norris (Guest)
on 2006-12-29 18:36
(Received via mailing list)
Fixed it.

Apparently I had capistrano 1.2.0 AND 1.3.0 installed. Apparently that
hosed something up, because I uninstalled the 3 version and now
everything works fine.
845b2f687d5e5882d0fe5e82d0931f21?d=identicon&s=25 Guest (Guest)
on 2006-12-29 18:52
Just as a note, thank you for letting us know the resolution.  I really
wish more people would give us closure on an issue like you did.
This topic is locked and can not be replied to.