Capistrano Help


#1

I’m trying to set up capistrano for one or more of my apps. I used it a
little bit successfully last week. Today I’m trying to set it up with a
real app. I did cap apply-to, then set up my deploy.rb. When I do cap
setup, I get this:

[root]# cap setup

  • executing task setup
  • executing “mkdir …”
    servers: [“web1”, “database”]
  • establishing connection to gateway 11.11.11.11
    starting connection to gateway 11.11.11.11
    Password:
    gateway connection established
    establishing connection to web1 via gateway
    establishing connection to database via gateway
    Net::SSH::AuthenticationFailed

I get in to the gateway just fine, and all the passwords are the same.
But it keeps failing.
I even tried setting up SSH for no password, still with no luck. Anyone
have this problem before and/or know what may be happening?
Thanks
Jason


#2

You’ll probably get more helpful responses in the Capistrano list.

http://groups.google.com/group/capistrano


#3

Fixed it.

Apparently I had capistrano 1.2.0 AND 1.3.0 installed. Apparently that
hosed something up, because I uninstalled the 3 version and now
everything works fine.


#4

Just as a note, thank you for letting us know the resolution. I really
wish more people would give us closure on an issue like you did.