Forum: JRuby Warbler 2.0.0.pre1 Released

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
666badca71c452ae51c999971419b506?d=identicon&s=25 Joe Kutner (Guest)
on 2015-04-29 22:54
(Received via mailing list)
I've release a 2.0.0.pre1 version of Warbler that is compatible with
JRuby
9.0.0.0.pre2, but is not compatible (in theory) with anything earlier.
https://rubygems.org/gems/warbler/versions/2.0.0.pre1

The plan for Warbler 2.x is essentially the same as JRuby 9k: only
supporting Ruby 2.2 onwards and some "modern" versions of Rails and
other
frameworks (we'll figure out the specifics as time goes on). Development
will be done on the 2.x-dev branch:
https://github.com/jruby/warbler/tree/2.x-dev

The Warbler 1.x version line *will continue to be supported* for as long
as
JRuby 1.7.x is supported. However, it will not support JRuby 9k. It will
also, probably, not support "modern" versions of Rails and such (see
above). Development will continue on the master branch until 2.0.0 is
released.

The 2.0.0.pre1 release is, otherwise, not that exciting. I mainly
updated
it to keep parity with 1.4.7 while running on JRuby 9k. Here's a summary
of
things:

* Removed all references to Merb (yup, you read that right)
* Removed support for Rails 2.x
* Removed support for Ruby 1.8 (yes, it's still there), 1.9, 2.0
* Removed some convoluted logic for loading bouncy castle jars

Here are some things I'm considering doing before a 2.0.0 release:

* Remove support for Rails 3.x (continue support on the Warbler 1.4.x
line)
* Remove Winstone? (make way for Tomcat?)
* Upgrade all tests to use modern versions of frameworks and Gems.
* Add first-class support for cool stuff from Servlet 3.1 via jruby-rack

Here are some example apps -- all of them ready to run on Heroku ;)

Dirt Simple Rack Example:
https://github.com/jkutner/warbler-rack-example

Sinatra (using Servlet 3.1 async) Example:
https://github.com/jkutner/warbler-sinatra-example

Rails 4.1 Example:
https://github.com/jkutner/warbler-rails-example

Please give this a try, and let me know if you find any problems.

I'd also love to hear suggestions for improvements, new features, or
other
things we should be supporting.

Cheers,

Joe Kutner
7098ab60af7b32bee65627bb36dfe74b?d=identicon&s=25 Aristedes Maniatis (Guest)
on 2015-04-30 02:27
(Received via mailing list)
On 30/04/2015 6:50am, Joe Kutner wrote:
> * Remove support for Rails 3.x (continue support on the Warbler 1.4.x line)

Unless there is a reason that Rails 3.x will not run on JRuby9k, please
don't do this. The Ruby ecosystem has a real problem working with
enterprise mainly because of this aggressive policy in forcing
developers to constantly upgrade libraries. 3.2 was the latest and
newest release of Rails only 22 months ago.

Please don't force us to upgrade everything at the same time.

Ari


--
-------------------------->
Aristedes Maniatis
ish
http://www.ish.com.au
Level 1, 30 Wilson Street Newtown 2042 Australia
phone +61 2 9550 5001   fax +61 2 9550 4001
GPG fingerprint CBFB 84B4 738D 4E87 5E5C  5EFA EF6A 7D2E 3E49 102A
666badca71c452ae51c999971419b506?d=identicon&s=25 Joe Kutner (Guest)
on 2015-04-30 17:38
(Received via mailing list)
Thanks for the feedback Ari. I definitely understand the rub. And
Warbler
has always erred on the side of keeping support (hence the Merb and 1.8
support in 1.4.7). I plan to continue this and I don't anticipate any
problems with Rails 3.2. I was just brainstorming.

I think it's totally reasonable to support, at the least, the latest
3.2.x
(as long as JRuby 9k does). And I won't kill anything earlier unless we
encounter problems.
This topic is locked and can not be replied to.