Forum: Ruby on Rails Problem installing Rails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
D52dc83b637fe5a386ab2ded09c29b00?d=identicon&s=25 Hari Natarajan (more2hari)
on 2006-03-27 21:34
Hi
 I am getting the following error when i tried to install rails in
windows using command prompt....

Attempting remote installation of 'rails'
Updating Gem source index for: http://gems.rubyforge.org
ERROR:  While executing gem ... (Gem::RemoteSourceException)
    Error fetching remote gem cache: getaddrinfo: no address associated
with hostname.

There are proxy settings in my institute and i need to set it up from
the command prompt? pls explain with an example..

Thanks in Advance..
C237cf537a06b60921c97804679e3b15?d=identicon&s=25 John Barnette (Guest)
on 2006-03-27 22:01
(Received via mailing list)
On 3/27/06, Hari Natarajan <hari_natraj@yahoo.com> wrote:
>
> There are proxy settings in my institute and i need to set it up from
> the command prompt? pls explain with an example..
>

Hari,

You can tell gem to use a proxy server by (I believe) either setting the
HTTP_PROXY environment variable, or by setting the -p (--http-proxy)
flag
when invoking gem. e.g.

$ export HTTP_PROXY=http://myproxy:80/
$ gem install foo

or

$ gem install --http-proxy http://myproxy:80/ foo


~ j.
8716cce9a7b721786e5425b8cc1f9951?d=identicon&s=25 sean lynch (Guest)
on 2006-03-27 22:03
I'm not the best person to answer Windows questions. Haven't used it for
a good long while. (emphasis on the 'good')

But if you know the url for your proxy, you can set up gem to go through
it

Look here:
http://docs.rubygems.org/read/chapter/13

in section 5.10

-sean

Hari Natarajan wrote:
> Hi
>  I am getting the following error when i tried to install rails in
> windows using command prompt....
>
> Attempting remote installation of 'rails'
> Updating Gem source index for: http://gems.rubyforge.org
> ERROR:  While executing gem ... (Gem::RemoteSourceException)
>     Error fetching remote gem cache: getaddrinfo: no address associated
> with hostname.
>
> There are proxy settings in my institute and i need to set it up from
> the command prompt? pls explain with an example..
>
> Thanks in Advance..
D52dc83b637fe5a386ab2ded09c29b00?d=identicon&s=25 Hari Natarajan (more2hari)
on 2006-03-27 22:09
thanx but i'm using windows and tats the problemm..if it hab been linux
i could have installed it earlier itself

John Barnette wrote:
> On 3/27/06, Hari Natarajan <hari_natraj@yahoo.com> wrote:
>>
>> There are proxy settings in my institute and i need to set it up from
>> the command prompt? pls explain with an example..
>>
>
> Hari,
>
> You can tell gem to use a proxy server by (I believe) either setting the
> HTTP_PROXY environment variable, or by setting the -p (--http-proxy)
> flag
> when invoking gem. e.g.
>
> $ export HTTP_PROXY=http://myproxy:80/
> $ gem install foo
>
> or
>
> $ gem install --http-proxy http://myproxy:80/ foo
>
>
> ~ j.
009c581be96c1c9a2da7da4741c9580b?d=identicon&s=25 Anonymous (Guest)
on 2006-04-27 00:54
(Received via mailing list)
Hi,
In Windows, you can directly set the environment variables in the
command prompt. Set the variables HTTP_PROXY, HTTP_PROXY_USER and
HTTP_PROXY_PASS, and then execute "gem install rails --remote".
This should make it work.
Thanks!!!
98988743c92ccb0612e5403b97c11039?d=identicon&s=25 Wifer (Guest)
on 2007-04-24 15:03
John Barnette wrote:
> On 3/27/06, Hari Natarajan <hari_natraj@yahoo.com> wrote:
>>
>> There are proxy settings in my institute and i need to set it up from
>> the command prompt? pls explain with an example..
>>
>
> Hari,
>
> You can tell gem to use a proxy server by (I believe) either setting the
> HTTP_PROXY environment variable, or by setting the -p (--http-proxy)
> flag
> when invoking gem. e.g.
>
> $ export HTTP_PROXY=http://myproxy:80/
> $ gem install foo
>
> or
>
> $ gem install --http-proxy http://myproxy:80/ foo
>
>
> ~ j.


EXCELENTE ME FUNCIONO CON
set HTTP_PROXY=http://MIPROXY:8080/
This topic is locked and can not be replied to.