Problem installing Rails

Hi
I am getting the following error when i tried to install rails in
windows using command prompt…

Attempting remote installation of ‘rails’
Updating Gem source index for: http://gems.rubyforge.org
ERROR: While executing gem … (Gem::RemoteSourceException)
Error fetching remote gem cache: getaddrinfo: no address associated
with hostname.

There are proxy settings in my institute and i need to set it up from
the command prompt? pls explain with an example…

Thanks in Advance…

On 3/27/06, Hari N. [email protected] wrote:

There are proxy settings in my institute and i need to set it up from
the command prompt? pls explain with an example…

Hari,

You can tell gem to use a proxy server by (I believe) either setting the
HTTP_PROXY environment variable, or by setting the -p (–http-proxy)
flag
when invoking gem. e.g.

$ export HTTP_PROXY=http://myproxy:80/
$ gem install foo

or

$ gem install --http-proxy http://myproxy:80/ foo

~ j.

I’m not the best person to answer Windows questions. Haven’t used it for
a good long while. (emphasis on the ‘good’)

But if you know the url for your proxy, you can set up gem to go through
it

Look here:
http://docs.rubygems.org/read/chapter/13

in section 5.10

-sean

Hari N. wrote:

Hi
I am getting the following error when i tried to install rails in
windows using command prompt…

Attempting remote installation of ‘rails’
Updating Gem source index for: http://gems.rubyforge.org
ERROR: While executing gem … (Gem::RemoteSourceException)
Error fetching remote gem cache: getaddrinfo: no address associated
with hostname.

There are proxy settings in my institute and i need to set it up from
the command prompt? pls explain with an example…

Thanks in Advance…

Hi,
In Windows, you can directly set the environment variables in the
command prompt. Set the variables HTTP_PROXY, HTTP_PROXY_USER and
HTTP_PROXY_PASS, and then execute “gem install rails --remote”.
This should make it work.
Thanks!!!

thanx but i’m using windows and tats the problemm…if it hab been linux
i could have installed it earlier itself

John B. wrote:

On 3/27/06, Hari N. [email protected] wrote:

There are proxy settings in my institute and i need to set it up from
the command prompt? pls explain with an example…

Hari,

You can tell gem to use a proxy server by (I believe) either setting the
HTTP_PROXY environment variable, or by setting the -p (–http-proxy)
flag
when invoking gem. e.g.

$ export HTTP_PROXY=http://myproxy:80/
$ gem install foo

or

$ gem install --http-proxy http://myproxy:80/ foo

~ j.

John B. wrote:

On 3/27/06, Hari N. [email protected] wrote:

There are proxy settings in my institute and i need to set it up from
the command prompt? pls explain with an example…

Hari,

You can tell gem to use a proxy server by (I believe) either setting the
HTTP_PROXY environment variable, or by setting the -p (–http-proxy)
flag
when invoking gem. e.g.

$ export HTTP_PROXY=http://myproxy:80/
$ gem install foo

or

$ gem install --http-proxy http://myproxy:80/ foo

~ j.

EXCELENTE ME FUNCIONO CON
set HTTP_PROXY=http://MIPROXY:8080/

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs