Forum: Ruby on Rails Could not install Rmagick Gem in rails 4 (Ubuntu 13.04)

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
8fa9ab47d7649632d492cf5efcba6c85?d=identicon&s=25 ANIL YADAV (Guest)
on 2014-08-27 10:28
(Received via mailing list)
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    /home/anil/.rvm/rubies/ruby-2.0.0-p481/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... no
Can't install RMagick 2.13.2. Can't find Magick-config in
/usr/local/heroku/bin:/home/anil/.rvm/gems/ruby-2.0.0-p481/bin:/home/anil/.rvm/gems/ruby-2.0.0-p481@global/bin:/home/anil/.rvm/rubies/ruby-2.0.0-p481/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/anil/.rvm/bin:/home/anil/.rvm/bin:/home/anil/.rvm/bin

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.
You
may
need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/home/anil/.rvm/rubies/ruby-2.0.0-p481/bin/ruby

extconf failed, exit code 1

Gem files will remain installed in
/home/anil/.rvm/gems/ruby-2.0.0-p481/gems/rmagick-2.13.2 for inspection.
Results logged to
/home/anil/.rvm/gems/ruby-2.0.0-p481/extensions/x86-linux/2.0.0/rmagick-2.13.2/gem_make.out
An error occurred while installing rmagick (2.13.2), and Bundler cannot
continue.
Make sure that `gem install rmagick -v '2.13.2'` succeeds before
bundling.
Bee69cfed999cd13e3bff73d472a39ee?d=identicon&s=25 Hassan Schroeder (Guest)
on 2014-08-27 12:56
(Received via mailing list)
On Wed, Aug 27, 2014 at 12:32 AM, ANIL YADAV <1993anilyadav@gmail.com>
wrote:

<snip/>

Is there a question to go with this?

--
Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
http://about.me/hassanschroeder
twitter: @hassan
8dba40d25bce0f1061fc2a3443d9d843?d=identicon&s=25 Benoit G. (benoit_g73)
on 2014-11-20 10:47
E8c9f700cf8778fcb35fea210aa78200?d=identicon&s=25 David Williams (darkruby2055)
on 2014-11-20 23:41
RMagick isn't compatible with the latest version of rails. The gem
hasn't been updated for sometime.
17c1d72be21a2a43be717c6dc1660c7b?d=identicon&s=25 Jim (Guest)
on 2014-11-21 15:18
(Received via mailing list)
On Thursday, November 20, 2014 5:43:06 PM UTC-5, Ruby-Forum.com User
wrote:
>
> RMagick isn't compatible with the latest version of rails. The gem
> hasn't been updated for sometime.


The OP is having an issue with the installation of the gem, which in
itself
has absolutely nothing to do with Rails of any version.  Besides that,
rmagick is compatible with Rails 4.

The current repository is at https://github.com/gemhome/rmagick and all
tickets should be placed there.

Jim
This topic is locked and can not be replied to.