Could not install Rmagick Gem in rails 4 (Ubuntu 13.04)


#1

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

/home/anil/.rvm/rubies/ruby-2.0.0-p481/bin/ruby extconf.rb

checking for Ruby version >= 1.8.5… yes
checking for gcc… yes
checking for Magick-config… no
Can’t install RMagick 2.13.2. Can’t find Magick-config in
/usr/local/heroku/bin:/home/anil/.rvm/gems/ruby-2.0.0-p481/bin:/home/anil/.rvm/gems/ruby-2.0.0-p481@global/bin:/home/anil/.rvm/rubies/ruby-2.0.0-p481/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/anil/.rvm/bin:/home/anil/.rvm/bin:/home/anil/.rvm/bin

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details.
You
may
need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/home/anil/.rvm/rubies/ruby-2.0.0-p481/bin/ruby

extconf failed, exit code 1

Gem files will remain installed in
/home/anil/.rvm/gems/ruby-2.0.0-p481/gems/rmagick-2.13.2 for inspection.
Results logged to
/home/anil/.rvm/gems/ruby-2.0.0-p481/extensions/x86-linux/2.0.0/rmagick-2.13.2/gem_make.out
An error occurred while installing rmagick (2.13.2), and Bundler cannot
continue.
Make sure that gem install rmagick -v '2.13.2' succeeds before
bundling.


#2

On Wed, Aug 27, 2014 at 12:32 AM, ANIL YADAV removed_email_address@domain.invalid
wrote:

Is there a question to go with this?


Hassan S. ------------------------ removed_email_address@domain.invalid
http://about.me/hassanschroeder
twitter: @hassan


#3

https://github.com/rmagick/rmagick/wiki/Installing-on-Ubuntu


#4

RMagick isn’t compatible with the latest version of rails. The gem
hasn’t been updated for sometime.


#5

On Thursday, November 20, 2014 5:43:06 PM UTC-5, Ruby-Forum.com User
wrote:

RMagick isn’t compatible with the latest version of rails. The gem
hasn’t been updated for sometime.

The OP is having an issue with the installation of the gem, which in
itself
has absolutely nothing to do with Rails of any version. Besides that,
rmagick is compatible with Rails 4.

The current repository is at https://github.com/gemhome/rmagick and all
tickets should be placed there.

Jim