Forum: GNU Radio Writing wav file in GMSK TX, RX

E9685919282bde5e925a361fa621a17d?d=identicon&s=25 dushyant.marathe (Guest)
on 2014-06-09 07:59
(Received via mailing list)
Hello list,

I am simulating Voice transmission system in GRC using 'GMSK Mod', 'GMSK
Demod' in loop without any channel in between & My flow graph
configuration
is as follows:

Wav file source -> Throttle -> Packet encoder -> GMSK Mod -> GMSK Demod
->
Packet decoder -> Wav file sink/Scope/FFT Sink.

When I execute the above flow graph, I get output at Scope, FFT Sink.
Also it writes wav file using 'Wav file sink' block, but I am not able
to
play that wav file, it gives error.

Please help me on above issue.

Thanks & Regards,
Dushyant






--
View this message in context:
http://gnuradio.4.n7.nabble.com/Writing-wav-file-i...
Sent from the GnuRadio mailing list archive at Nabble.com.
739a038d5a03d5448114b3615e2caedc?d=identicon&s=25 Activecat K. (activecat_k)
on 2014-06-09 08:32
(Received via mailing list)
On Mon, Jun 9, 2014 at 1:57 PM, dushyant.marathe
<dushyantmarathe@gmail.com>
wrote:

> Also it writes wav file using 'Wav file sink' block, but I am not able to
> play that wav file, it gives error.
>


You didn't mention how you played the wave file.
Take note that in gnuradio, audio sink accepts floating point samples in
the range of -1 and +1. [1]
Beyond the range you will get clipping error.

1.
http://gnuradio.org/redmine/projects/gnuradio/wiki...
E9685919282bde5e925a361fa621a17d?d=identicon&s=25 dushyant.marathe (Guest)
on 2014-06-09 08:58
(Received via mailing list)
Hi Activecat,

Thanks for the reply.

I am playing wav file using windows media player. When I execute the
flow
graph it writes wav file. Wav file's size increases, unless I stop the
flow
graph. But when I played it using media player it doesn't play any more.

Also I am ensuring that amplitude is in the range of -1 and +1.

Plz note that I am not using Audio sink. I am using 'Wav sink block'

I want to tell you that, I am using Gnu Radio 3.7.3. Moreover My Ubuntu
12.04 is installed on Virtual machine.

Regards,
Dushyant



--
View this message in context:
http://gnuradio.4.n7.nabble.com/Writing-wav-file-i...
Sent from the GnuRadio mailing list archive at Nabble.com.
F18b7b61dfbfe46c7af3cbcbda568c4f?d=identicon&s=25 Vanush Vaswani (Guest)
on 2014-06-09 09:13
(Received via mailing list)
Make sure you close the .wav file by pressing 'x' (close) button on a
graphical sink, otherwise it won't write the wav file correctly.
Check here: http://gnuradio.org/redmine/issues/544

Otherwise, try playing in VLC.


On Mon, Jun 9, 2014 at 4:57 PM, dushyant.marathe
<dushyantmarathe@gmail.com>
739a038d5a03d5448114b3615e2caedc?d=identicon&s=25 Activecat K. (activecat_k)
on 2014-06-09 09:24
(Received via mailing list)
On Mon, Jun 9, 2014 at 2:57 PM, dushyant.marathe
<dushyantmarathe@gmail.com>
wrote:

> Plz note that I am not using Audio sink. I am using 'Wav sink block'
>
> I want to tell you that, I am using Gnu Radio 3.7.3. Moreover My Ubuntu
> 12.04 is installed on Virtual machine.
>
> Regards,
> Dushyant
>


To isolate the problem, try this:
1). Execute this flowgraph:  Wav File Source --> Packet Encoder -->
Packet
Decoder --> Wav File Sink.
2). Try to play the wav file produced.

This is to ensure there is no problem with the settings of Packet
Encoder/Decoder.
739a038d5a03d5448114b3615e2caedc?d=identicon&s=25 Activecat K. (activecat_k)
on 2014-06-09 09:50
(Received via mailing list)
Attachment: 9012_wav_file_sink.grc.png (50 KB)
Attachment: 9012_wav_file_sink.grc.png (50 KB)
_______________________________________________
Discuss-gnuradio mailing list
Discuss-gnuradio@gnu.org
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.