Writing wav file in GMSK TX, RX

Hello list,

I am simulating Voice transmission system in GRC using ‘GMSK Mod’, ‘GMSK
Demod’ in loop without any channel in between & My flow graph
configuration
is as follows:

Wav file source -> Throttle -> Packet encoder -> GMSK Mod -> GMSK Demod
->
Packet decoder -> Wav file sink/Scope/FFT Sink.

When I execute the above flow graph, I get output at Scope, FFT Sink.
Also it writes wav file using ‘Wav file sink’ block, but I am not able
to
play that wav file, it gives error.

Please help me on above issue.

Thanks & Regards,
Dushyant


View this message in context:
http://gnuradio.4.n7.nabble.com/Writing-wav-file-in-GMSK-TX-RX-tp48857.html
Sent from the GnuRadio mailing list archive at Nabble.com.

On Mon, Jun 9, 2014 at 1:57 PM, dushyant.marathe
[email protected]
wrote:

Also it writes wav file using ‘Wav file sink’ block, but I am not able to
play that wav file, it gives error.

You didn’t mention how you played the wave file.
Take note that in gnuradio, audio sink accepts floating point samples in
the range of -1 and +1. [1]
Beyond the range you will get clipping error.

http://gnuradio.org/redmine/projects/gnuradio/wiki/TutorialsWritePythonApplications#A-first-working-code-example

Hi Activecat,

Thanks for the reply.

I am playing wav file using windows media player. When I execute the
flow
graph it writes wav file. Wav file’s size increases, unless I stop the
flow
graph. But when I played it using media player it doesn’t play any more.

Also I am ensuring that amplitude is in the range of -1 and +1.

Plz note that I am not using Audio sink. I am using ‘Wav sink block’

I want to tell you that, I am using Gnu Radio 3.7.3. Moreover My Ubuntu
12.04 is installed on Virtual machine.

Regards,
Dushyant


View this message in context:
http://gnuradio.4.n7.nabble.com/Writing-wav-file-in-GMSK-TX-RX-tp48857p48860.html
Sent from the GnuRadio mailing list archive at Nabble.com.

Make sure you close the .wav file by pressing ‘x’ (close) button on a
graphical sink, otherwise it won’t write the wav file correctly.
Check here: http://gnuradio.org/redmine/issues/544

Otherwise, try playing in VLC.

On Mon, Jun 9, 2014 at 4:57 PM, dushyant.marathe
[email protected]

On Mon, Jun 9, 2014 at 2:57 PM, dushyant.marathe
[email protected]
wrote:

Plz note that I am not using Audio sink. I am using ‘Wav sink block’

I want to tell you that, I am using Gnu Radio 3.7.3. Moreover My Ubuntu
12.04 is installed on Virtual machine.

Regards,
Dushyant

To isolate the problem, try this:
1). Execute this flowgraph: Wav File Source --> Packet Encoder -->
Packet
Decoder --> Wav File Sink.
2). Try to play the wav file produced.

This is to ensure there is no problem with the settings of Packet
Encoder/Decoder.


Discuss-gnuradio mailing list
[email protected]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs