Forum: Ruby on Rails "no such file to load -- my_extensions (MissingSourceFile)"

58fcb2f9e4371143e1965eac84505ee5?d=identicon&s=25 Toby Rodwell (tobyr)
on 2013-12-21 01:48
I have a Rails application runnng on one machien quite happily, using
Ruby 1.9.1-p243 and Rails 2.3.3.  I copied the app and config folders to
another machine, on which I'm also running 1.9.1-p243, but via RVM.
Whenever I try to launch the Rails application ('server', 'runner',
'console') I get the error message  "no such file to load --
my_extensions (MissingSourceFile)".

Based on one googled suggestion I created a nearly empty file,
$ROOT/config/initializers/my_extensions.rb
but this did not help.  I'm also wondering if I need to create a
'wrapper' as I've seen this mentioned int he contect of using Rails and
RVM - but I can't see what I would need to do for, say, 'ruuner'.  All
advice gratefully received.
Aa082c8b00a50928e5860dcd70bf2368?d=identicon&s=25 tamouse m. (tamouse_m)
on 2013-12-21 05:31
(Received via mailing list)
On Fri, Dec 20, 2013 at 6:48 PM, Toby Rodwell <lists@ruby-forum.com>
wrote:

> 'wrapper' as I've seen this mentioned int he contect of using Rails and
> RVM - but I can't see what I would need to do for, say, 'ruuner'.  All
> advice gratefully received.
>

So, really no idea what's going on here, but it sounds like there's a
library of my_extensions.rb someplace that maybe didn't get copied over,
or
wasn't bundled correctly? Look through the Gemfile, the Gemfile.lock,
the
old installation, etc. Sorry if you've already gone over all that, I
just
am taking a shot in the dark.
4c6bde00168d595053c09aac7e487f8e?d=identicon&s=25 Colin Law (Guest)
on 2013-12-21 10:05
(Received via mailing list)
On 21 December 2013 00:48, Toby Rodwell <lists@ruby-forum.com> wrote:
> I have a Rails application runnng on one machien quite happily, using
> Ruby 1.9.1-p243 and Rails 2.3.3.  I copied the app and config folders to
> another machine, on which I'm also running 1.9.1-p243, but via RVM.
> Whenever I try to launch the Rails application ('server', 'runner',
> 'console') I get the error message  "no such file to load --
> my_extensions (MissingSourceFile)".

Post the full error including the stack trace if there is one.  First
have a good look at it though to see if it tells you where it is being
included from.  Also do a full text search on the original machine
looking for 'my_extensions' and 'MyExtensions' and do a file search
for my_extensions.rb

Colin
58fcb2f9e4371143e1965eac84505ee5?d=identicon&s=25 Toby Rodwell (tobyr)
on 2013-12-22 20:18
Many thanks to you both - indeed, I was being a muppet, and it's exactly
as you suspected, namely I'd forgotten to copy across a file.  Grep'ing
for the file name helped me track it down.  Thanks again and Merry
Christmas!
6883e5ef03484d4fcef507d7b4f1d243?d=identicon&s=25 Matt Jones (Guest)
on 2013-12-26 03:09
(Received via mailing list)
On Sunday, 22 December 2013 14:18:40 UTC-5, Ruby-Forum.com User wrote:
>
> Many thanks to you both - indeed, I was being a muppet, and it's exactly
> as you suspected, namely I'd forgotten to copy across a file.  Grep'ing
> for the file name helped me track it down.  Thanks again and Merry
> Christmas!
>
>
FWIW, do yourself a favor and pick a source control system. Deploying
apps
by copying files WILL bite you (scratch that, HAS bitten you) in
unexpected
ways.

--Matt Jones
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.