Forum: Ruby Ruby - Ruote

47f7d8a30661b95722e39f2d015fe113?d=identicon&s=25 Fábio Pereira (fabiompereira)
on 2013-10-22 19:09
Good afternoon, in order to complete a task for a schoolar subject me
and my group had to install Ruote. We have already installed ruby and we
managed how to install Ruote but we can't understand how it works or it
is supposed to do. Does anyone have some experience working on Route
that can give me a short explanation?
91e1fb8bd265b7629491ab64c42f0906?d=identicon&s=25 Reid Thompson (Guest)
on 2013-10-23 16:42
(Received via mailing list)
On Tue, 2013-10-22 at 19:09 +0200, Fábio Pereira wrote:

> Good afternoon, in order to complete a task for a schoolar subject me
> and my group had to install Ruote. We have already installed ruby and we
> managed how to install Ruote but we can't understand how it works or it
> is supposed to do. Does anyone have some experience working on Route
> that can give me a short explanation?
>

https://github.com/jmettraux/ruote/blob/master/qui...
47f7d8a30661b95722e39f2d015fe113?d=identicon&s=25 Fábio Pereira (fabiompereira)
on 2013-10-23 17:07
I have installed the ruote without dependencies (gem isntall ruote
--ignore--dependencies), and now when in try to run any ruote-ruby file
the ruby say that miss dependencies.
i can't install route with dependencies :x
14b5582046b4e7b24ab69b7886a35868?d=identicon&s=25 Joel Pearson (virtuoso)
on 2013-10-23 17:11
Explain why you can't install route with dependencies? Obviously, it
depends on its dependencies and cannot run without them.
47f7d8a30661b95722e39f2d015fe113?d=identicon&s=25 Fábio Pereira (fabiompereira)
on 2013-10-23 17:16
root@ubuntu:~# gem install ruote --include-dependencies
INFO:  `gem install -y` is now default and will be removed
INFO:  use --ignore-dependencies to install only the gems you list

root@ubuntu:~# gem install ruote --development
ERROR:  While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)
47f7d8a30661b95722e39f2d015fe113?d=identicon&s=25 Fábio Pereira (fabiompereira)
on 2013-10-23 17:20
root@ubuntu:~# gem install ruby_parser
Successfully installed ruby_parser-3.2.2
1 gem installed
Installing ri documentation for ruby_parser-3.2.2...
Installing RDoc documentation for ruby_parser-3.2.2...
root@ubuntu:~# gem install ruote
ERROR:  While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)
75eb154a2d05884a8a6a8e54b6eb3deb?d=identicon&s=25 Wayne Brisette (Guest)
on 2013-10-23 17:28
(Received via mailing list)
There's obviously something wrong with that gem!

gem install ruby_parser
Fetching: sexp_processor-4.4.0.gem (100%)
Fetching: ruby_parser-3.2.2.gem (100%)
Successfully installed sexp_processor-4.4.0
Successfully installed ruby_parser-3.2.2
2 gems installed
Installing ri documentation for sexp_processor-4.4.0...
Installing ri documentation for ruby_parser-3.2.2...
Installing RDoc documentation for sexp_processor-4.4.0...
Installing RDoc documentation for ruby_parser-3.2.2...

wayneb ~ $ gem install ruote
ERROR: While executing gem ... (Gem::DependencyError)
  Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)
wayneb ~ $

(I'm on Mac OS X, by the way).




________________________________
 From: Fbio Pereira <lists@ruby-forum.com>
To: ruby-talk@ruby-lang.org
Sent: Wednesday, October 23, 2013 10:20 AM
Subject: Re: Ruby - Ruote


root@ubuntu:~# gem install ruby_parser
Successfully installed ruby_parser-3.2.2
1 gem installed
Installing ri documentation for ruby_parser-3.2.2...
Installing RDoc documentation for ruby_parser-3.2.2...
root@ubuntu:~# gem install ruote
ERROR: While executing gem ... (Gem::DependencyError)
  Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)
75eb154a2d05884a8a6a8e54b6eb3deb?d=identicon&s=25 Wayne Brisette (Guest)
on 2013-10-23 17:32
(Received via mailing list)
I should point out that by looking at the documentation they have their
own discussion group:

https://groups.google.com/forum/#!forum/openwferu-users


I would suggest you see what they have to say about this issue.
Aa082c8b00a50928e5860dcd70bf2368?d=identicon&s=25 tamouse m. (tamouse_m)
on 2013-10-24 08:19
(Received via mailing list)
On Oct 23, 2013, at 10:28 AM, Wayne Brisette <wbrisett@att.net> wrote:

> There's obviously something wrong with that gem!

Not exactly, just the wrong version of ruby_parser was installed.

>
>  gem install ruby_parser
> Fetching: sexp_processor-4.4.0.gem (100%)
> Fetching: ruby_parser-3.2.2.gem (100%)
> Successfully installed sexp_processor-4.4.0
> Successfully installed ruby_parser-3.2.2

Installed major version 3 here.

> 2 gems installed
> Installing ri documentation for sexp_processor-4.4.0...
> Installing ri documentation for ruby_parser-3.2.2...
> Installing RDoc documentation for sexp_processor-4.4.0...
> Installing RDoc documentation for ruby_parser-3.2.2...
>
> wayneb ~ $ gem install ruote
> ERROR:  While executing gem ... (Gem::DependencyError)
>     Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)

This indicates that ruote needs a version no greater than 2.3 (it will
accept any build on that minor version of 3)  which 3.2.2 is.

So up above, you need to install a lower version of ruby_parser:

gem install ruby_parser version 2.3
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.