Ruby - Ruote

Good afternoon, in order to complete a task for a schoolar subject me
and my group had to install Ruote. We have already installed ruby and we
managed how to install Ruote but we can’t understand how it works or it
is supposed to do. Does anyone have some experience working on Route
that can give me a short explanation?

On Tue, 2013-10-22 at 19:09 +0200, Fábio Pereira wrote:

Good afternoon, in order to complete a task for a schoolar subject me
and my group had to install Ruote. We have already installed ruby and we
managed how to install Ruote but we can’t understand how it works or it
is supposed to do. Does anyone have some experience working on Route
that can give me a short explanation?

https://github.com/jmettraux/ruote/blob/master/quickstart/quickstart.rb

I have installed the ruote without dependencies (gem isntall ruote
–ignore–dependencies), and now when in try to run any ruote-ruby file
the ruby say that miss dependencies.
i can’t install route with dependencies :x

[email protected]:~# gem install ruote --include-dependencies
INFO: gem install -y is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list

[email protected]:~# gem install ruote --development
ERROR: While executing gem … (Gem::DependencyError)
Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)

Explain why you can’t install route with dependencies? Obviously, it
depends on its dependencies and cannot run without them.

[email protected]:~# gem install ruby_parser
Successfully installed ruby_parser-3.2.2
1 gem installed
Installing ri documentation for ruby_parser-3.2.2…
Installing RDoc documentation for ruby_parser-3.2.2…
[email protected]:~# gem install ruote
ERROR: While executing gem … (Gem::DependencyError)
Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)

There’s obviously something wrong with that gem!

gem install ruby_parser
Fetching: sexp_processor-4.4.0.gem (100%)
Fetching: ruby_parser-3.2.2.gem (100%)
Successfully installed sexp_processor-4.4.0
Successfully installed ruby_parser-3.2.2
2 gems installed
Installing ri documentation for sexp_processor-4.4.0…
Installing ri documentation for ruby_parser-3.2.2…
Installing RDoc documentation for sexp_processor-4.4.0…
Installing RDoc documentation for ruby_parser-3.2.2…

wayneb ~ $ gem install ruote
ERROR: While executing gem … (Gem::DependencyError)
Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)
wayneb ~ $

(I’m on Mac OS X, by the way).


From: Fbio P. [email protected]
To: [email protected]
Sent: Wednesday, October 23, 2013 10:20 AM
Subject: Re: Ruby - Ruote

[email protected]:~# gem install ruby_parser
Successfully installed ruby_parser-3.2.2
1 gem installed
Installing ri documentation for ruby_parser-3.2.2…
Installing RDoc documentation for ruby_parser-3.2.2…
[email protected]:~# gem install ruote
ERROR: While executing gem … (Gem::DependencyError)
Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)

On Oct 23, 2013, at 10:28 AM, Wayne B. [email protected] wrote:

There’s obviously something wrong with that gem!

Not exactly, just the wrong version of ruby_parser was installed.

gem install ruby_parser
Fetching: sexp_processor-4.4.0.gem (100%)
Fetching: ruby_parser-3.2.2.gem (100%)
Successfully installed sexp_processor-4.4.0
Successfully installed ruby_parser-3.2.2

Installed major version 3 here.

2 gems installed
Installing ri documentation for sexp_processor-4.4.0…
Installing ri documentation for ruby_parser-3.2.2…
Installing RDoc documentation for sexp_processor-4.4.0…
Installing RDoc documentation for ruby_parser-3.2.2…

wayneb ~ $ gem install ruote
ERROR: While executing gem … (Gem::DependencyError)
Unable to resolve dependencies: ruote requires ruby_parser (~> 2.3)

This indicates that ruote needs a version no greater than 2.3 (it will
accept any build on that minor version of 3) which 3.2.2 is.

So up above, you need to install a lower version of ruby_parser:

gem install ruby_parser version 2.3

I should point out that by looking at the documentation they have their
own discussion group:

https://groups.google.com/forum/#!forum/openwferu-users

I would suggest you see what they have to say about this issue.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs