Forum: Italian Ruby user group rvm su macchina virtuale bitnami

71845161952bbfcb58f4e474164453ef?d=identicon&s=25 asd asd (cris_1986)
on 2013-07-20 14:22
ciao a tutti,
sto installando delle differenti versioni di ruby su una macchina
virtuale bitnami con stack ruby.

accedo alla ruby console come da documentazione ufficiale:
sudo /opt/bitnami/rubyconsole

installo la versione di cui necessito:
rvm install 2.0.0


tutto fila liscio tranne che ottengo questo warning di cui ignoro il
reale significato:
No binary rubies available for: ubuntu/12.04/x86_64/ruby-2.0.0-p0.
Continuing with compilation. Please read 'rvm mount' to get more
information on binary rubies.


qualcuno ha qualche idea?!
2dd4747f79885cbdb629d703a9a64ff4?d=identicon&s=25 Rocco Galluzzo (byterussian)
on 2013-07-20 14:38
(Received via mailing list)
Rvm cerca se sono presenti pacchetti gi compilati per la tua
distribuzione, non essendoci scarica il sorgente e compila il tutto,
ergo
nessun problema se compare solo questo warning.

Nota: la versione ruby-2.0.0 pi recente  la
2.0.0-p247<http://www.ruby-lang.org/en/news/2013/06/27/ruby-2...
rvm ti ha installato la 2.0.0-p0, se vuoi aggiornarla devi scrivere
sulla console: rvm get e poi  rvm upgrade 2.0.0

Ciao


2013/7/20 asd asd <magicogregnaz@msn.com>
71845161952bbfcb58f4e474164453ef?d=identicon&s=25 asd asd (cris_1986)
on 2013-07-21 15:25
ciao grazie per la risposta.
Ho lanciato rvm get ma ottengo:
Could not update RVM, get some help at #rvm IRC channel at freenode
servers.

se lancio rvm list ottengo:


root@linux:~# rvm list

rvm rubies

   ruby-1.9.3-p392 [ x86_64 ]
   ruby-1.9.3-p448 [ x86_64 ]
   ruby-2.0.0-p0 [ x86_64 ]
   ruby-2.0.0-p247 [ x86_64 ]

# Default ruby not set. Try 'rvm alias create default <ruby>'.

# => - current
# =* - current && default
#  * - default
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2013-07-21 15:43
(Received via mailing list)
Dall'output del comando vedo che in un modo o nell'altro hai ottenuto
anche
l'ultima versione della 2.0 :-)
Ti consiglio di impostare il default ruby, come suggerito anche dal
comando
rvm list:

rvm use ruby-2.0.0-p247 --default

un altro modo di ottenere lo stesso comando dovrebbe essere:

ruby use 2.0

per accertartene rilancia in seguito rvm list.
71845161952bbfcb58f4e474164453ef?d=identicon&s=25 asd asd (cris_1986)
on 2013-07-21 15:52
Si non so come ho fatto ma di fatto ho messo l ultima. :)
ora ho impostato come default la 2.0.0-p247

Ho un dubbio: ogni volta che riavvio poi devo impostare di nuovo la
versione?
5ffafe70176a99f175d16192fd5be69e?d=identicon&s=25 Luca P. (luca_p)
on 2013-07-21 16:05
(Received via mailing list)
Dipende, se hai usato --default user sempre quella.
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.