Rvm su macchina virtuale bitnami

ciao a tutti,
sto installando delle differenti versioni di ruby su una macchina
virtuale bitnami con stack ruby.

accedo alla ruby console come da documentazione ufficiale:
sudo /opt/bitnami/rubyconsole

installo la versione di cui necessito:
rvm install 2.0.0

tutto fila liscio tranne che ottengo questo warning di cui ignoro il
reale significato:
No binary rubies available for: ubuntu/12.04/x86_64/ruby-2.0.0-p0.
Continuing with compilation. Please read ‘rvm mount’ to get more
information on binary rubies.

qualcuno ha qualche idea?!

Rvm cerca se sono presenti pacchetti gi compilati per la tua
distribuzione, non essendoci scarica il sorgente e compila il tutto,
ergo
nessun problema se compare solo questo warning.

Nota: la versione ruby-2.0.0 pi recente la
2.0.0-p247http://www.ruby-lang.org/en/news/2013/06/27/ruby-2-0-0-p247-is-released/mentre
rvm ti ha installato la 2.0.0-p0, se vuoi aggiornarla devi scrivere
sulla console: rvm get e poi rvm upgrade 2.0.0

Ciao

2013/7/20 asd asd [email protected]

ciao grazie per la risposta.
Ho lanciato rvm get ma ottengo:
Could not update RVM, get some help at #rvm IRC channel at freenode
servers.

se lancio rvm list ottengo:

[email protected]:~# rvm list

rvm rubies

ruby-1.9.3-p392 [ x86_64 ]
ruby-1.9.3-p448 [ x86_64 ]
ruby-2.0.0-p0 [ x86_64 ]
ruby-2.0.0-p247 [ x86_64 ]

Default ruby not set. Try 'rvm alias create default '.

=> - current

=* - current && default

* - default

Dall’output del comando vedo che in un modo o nell’altro hai ottenuto
anche
l’ultima versione della 2.0 :slight_smile:
Ti consiglio di impostare il default ruby, come suggerito anche dal
comando
rvm list:

rvm use ruby-2.0.0-p247 --default

un altro modo di ottenere lo stesso comando dovrebbe essere:

ruby use 2.0

per accertartene rilancia in seguito rvm list.

Si non so come ho fatto ma di fatto ho messo l ultima. :slight_smile:
ora ho impostato come default la 2.0.0-p247

Ho un dubbio: ogni volta che riavvio poi devo impostare di nuovo la
versione?

Dipende, se hai usato --default user sempre quella.