Forum: Ruby-Gnome 2 Error Running Vr - Glib2.so [LoadError]

110e48b472a1e363841522425a82af26?d=identicon&s=25 Gabriel Ramat (dirmada)
on 2013-03-14 09:25
Hello,

After successful install of visualruby, I got the error message when
trying to run 'vr' on command prompt. Please, If somebody could help,
that will be nice.

C:\Ruby193\lib\ruby\gems\1.9.1\cache>vr
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in
`require': 126: Le module spÚcifiÚ est introuvable.
   -
C:/Ruby193/lib/ruby/gems/1.9.1/gems/glib2-1.2.2-x86-mingw32/lib/glib2.so
(LoadError)
        from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in
`rescue in require'
        from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in
`require'
        from
C:/Ruby193/lib/ruby/gems/1.9.1/gems/glib2-1.2.2-x86-mingw32/lib/glib2.rb:100:in
`rescue in <top (required)>
'
        from
C:/Ruby193/lib/ruby/gems/1.9.1/gems/glib2-1.2.2-x86-mingw32/lib/glib2.rb:96:in
`<top (required)>'
        from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
C:/Ruby193/lib/ruby/gems/1.9.1/gems/gtk2-1.2.2-x86-mingw32/lib/gtk2/base.rb:12:in
`<top (required)>'
        from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
C:/Ruby193/lib/ruby/gems/1.9.1/gems/gtk2-1.2.2-x86-mingw32/lib/gtk2.rb:11:in
`<top (required)>'
        from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
C:/Ruby193/lib/ruby/gems/1.9.1/gems/visualruby-0.1.2/vr:5:in `<top
(required)>'
        from C:/Ruby193/bin/vr:23:in `load'
        from C:/Ruby193/bin/vr:23:in `<main>'

OS : Win32 - Xp
Ee6ffca720cc428d70247dcd7377dd48?d=identicon&s=25 Kouhei Sutou (Guest)
on 2013-03-17 11:35
(Received via mailing list)
Hi,

In <54894dbffa788e6ccd5a8cb3a7a1a1c7@ruby-forum.com>
  "[ruby-gnome2-devel-en] Error Running Vr - Glib2.so [LoadError]" on
Thu, 14 Mar 2013 09:25:47 +0100,
  Gabriel Ramat <ruby-forum-incoming@andreas-s.net> wrote:

>         from
> C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in
> `rescue in require'

Sorry. Ruby-GNOME2 1.2.2 packages for Windows are broken.
I've released Ruby-GNOME2 1.2.3 and created packages for
Windows. Could you try again?


Thanks,
--
kou
110e48b472a1e363841522425a82af26?d=identicon&s=25 Gabriel Ramat (dirmada)
on 2013-03-18 07:35
Hi,

Thanks for replying, and the Ruby-GNOME2 1.2.3 made it perfectly. It
works now ! Good job!

Gab.
Ee6ffca720cc428d70247dcd7377dd48?d=identicon&s=25 Kouhei Sutou (Guest)
on 2013-03-18 12:32
(Received via mailing list)
Hi,

In <de4fa6f809b1279b68b4cedf242f268d@ruby-forum.com>
  "Re: [ruby-gnome2-devel-en] Error Running Vr - Glib2.so [LoadError]"
on Mon, 18 Mar 2013 07:35:55 +0100,
  Gabriel Ramat <ruby-forum-incoming@andreas-s.net> wrote:

> Thanks for replying, and the Ruby-GNOME2 1.2.3 made it perfectly. It
> works now ! Good job!

Thanks for confirming it. :-)
It's good news.

--
kou
D1de10529096818a6a75c7af6a1f0f7d?d=identicon&s=25 Emmanuel A. (emmanuel_a)
on 2013-05-15 14:39
Audu James
> Hi,
>
> In <de4fa6f809b1279b68b4cedf242f268d@ruby-forum.com>
>   "Re: [ruby-gnome2-devel-en] Error Running Vr - Glib2.so [LoadError]"
> on Mon, 18 Mar 2013 07:35:55 +0100,
>   Gabriel Ramat <ruby-forum-incoming@andreas-s.net> wrote:
>
>> Sorry please, but are we meant to install the gnome 1.2.3 for it to work or
just retry running the visualruby
> --
>
D092ec4a08d1a0a738d5b35ebee7fb26?d=identicon&s=25 Aymar A. (aymar_a)
on 2013-06-14 11:05
hi!
>>> Sorry please, but are we meant to install the gnome 1.2.3 for it to work or
 just retry running the visualruby

You have to install the gnome 1.2.3
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.