Error Running Vr - Glib2.so [LoadError]

Hello,

After successful install of visualruby, I got the error message when
trying to run ‘vr’ on command prompt. Please, If somebody could help,
that will be nice.

C:\Ruby193\lib\ruby\gems\1.9.1\cache>vr
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in
`require’: 126: Le module spÚcifiÚ est introuvable.

C:/Ruby193/lib/ruby/gems/1.9.1/gems/glib2-1.2.2-x86-mingw32/lib/glib2.so
(LoadError)
from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in
rescue in require' from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:inrequire’
from
C:/Ruby193/lib/ruby/gems/1.9.1/gems/glib2-1.2.2-x86-mingw32/lib/glib2.rb:100:in
rescue in <top (required)> ' from C:/Ruby193/lib/ruby/gems/1.9.1/gems/glib2-1.2.2-x86-mingw32/lib/glib2.rb:96:in<top (required)>’
from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire’
from
C:/Ruby193/lib/ruby/gems/1.9.1/gems/gtk2-1.2.2-x86-mingw32/lib/gtk2/base.rb:12:in
<top (required)>' from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire’
from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from C:/Ruby193/lib/ruby/gems/1.9.1/gems/gtk2-1.2.2-x86-mingw32/lib/gtk2.rb:11:in<top (required)>’
from
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require' from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire’
from
C:/Ruby193/lib/ruby/gems/1.9.1/gems/visualruby-0.1.2/vr:5:in <top (required)>' from C:/Ruby193/bin/vr:23:inload’
from C:/Ruby193/bin/vr:23:in `’

OS : Win32 - Xp

Hi,

Thanks for replying, and the Ruby-GNOME2 1.2.3 made it perfectly. It
works now ! Good job!

Gab.

Hi,

In [email protected]
“Re: [ruby-gnome2-devel-en] Error Running Vr - Glib2.so [LoadError]”
on Mon, 18 Mar 2013 07:35:55 +0100,
Gabriel R. [email protected] wrote:

Thanks for replying, and the Ruby-GNOME2 1.2.3 made it perfectly. It
works now ! Good job!

Thanks for confirming it. :slight_smile:
It’s good news.


kou

Audu James

Hi,

In [email protected]
“Re: [ruby-gnome2-devel-en] Error Running Vr - Glib2.so [LoadError]”
on Mon, 18 Mar 2013 07:35:55 +0100,
Gabriel R. [email protected] wrote:

Sorry please, but are we meant to install the gnome 1.2.3 for it to work or
just retry running the visualruby

hi!

Sorry please, but are we meant to install the gnome 1.2.3 for it to work or
just retry running the visualruby

You have to install the gnome 1.2.3

Hi,

In [email protected]
“[ruby-gnome2-devel-en] Error Running Vr - Glib2.so [LoadError]” on
Thu, 14 Mar 2013 09:25:47 +0100,
Gabriel R. [email protected] wrote:

    from

C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in
`rescue in require’

Sorry. Ruby-GNOME2 1.2.2 packages for Windows are broken.
I’ve released Ruby-GNOME2 1.2.3 and created packages for
Windows. Could you try again?

Thanks,

kou

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs