Forum: Ruby on Rails cookbook no running in production

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
998baab37c607466125c1235c1ad7006?d=identicon&s=25 Frank Rocco (frocco)
on 2005-12-05 20:49
(Received via mailing list)
Hello,

I have cookbook running on my pc, when I move it to our production
server, I get a page not found.

If I just type http://web:8082/cookbook it brings up the welcome page.

when I type http:web:8082/cookbook/categories
it displays page not found

I have mysql on both machines.
I had to change the password in the cookbook config for the mysql
production server

Any ideas what might be causing this?

Thanks

Frank
93aea4ff5331ee2c926cebd8df6be579?d=identicon&s=25 Jm Mc (railsnewb)
on 2005-12-05 22:35
(Received via mailing list)
Try something like
http://web:8082/recipe/list
or
http://web:8082/category/list

I assume you are referring to the ONlamp tutorial.





--- Frank <farocco@hotmail.com> wrote:

>
> I have mysql on both machines.
> I had to change the password in the cookbook config
> for the mysql production server
>
> Any ideas what might be causing this?
>
> Thanks
>
> Frank>
_______________________________________________
> Rails mailing list
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails
>






__________________________________________
Yahoo! DSL ? Something to write home about.
Just $16.99/mo. or less.
dsl.yahoo.com
998baab37c607466125c1235c1ad7006?d=identicon&s=25 Frank Rocco (frocco)
on 2005-12-05 22:48
(Received via mailing list)
Still not working.

If I just do a http://web:8082
I get

Forbidden
You don't have permission to access / on this server.



What should I do?

----- Original Message -----
From: "jonathan Mcintire" <hatejonny@yahoo.com>
To: <rails@lists.rubyonrails.org>
Sent: Monday, December 05, 2005 4:35 PM
Subject: Re: [Rails] cookbook no running in production
998baab37c607466125c1235c1ad7006?d=identicon&s=25 Frank Rocco (frocco)
on 2005-12-05 22:48
(Received via mailing list)
It works if I run WebBrick, I need apache to work.

Thanks
Frank
----- Original Message -----
From: "jonathan Mcintire" <hatejonny@yahoo.com>
To: <rails@lists.rubyonrails.org>
Sent: Monday, December 05, 2005 4:35 PM
Subject: Re: [Rails] cookbook no running in production
4353600bbb6b6e0950e62f7f44e49dd5?d=identicon&s=25 ssmith (Guest)
on 2005-12-06 04:29
(Received via mailing list)
You may want to check your Apache log files to see if there are any
errors reported there.
998baab37c607466125c1235c1ad7006?d=identicon&s=25 Frank Rocco (frocco)
on 2005-12-06 15:38
(Received via mailing list)
[Tue Dec 06 09:35:52 2005] [error] [client 10.10.20.41] (OS 21)The
device is
not ready.  : couldn't create child process: 720021: dispatch.cgi
[Tue Dec 06 09:35:52 2005] [error] [client 10.10.20.41] (OS 21)The
device is
not ready.  : couldn't spawn child process:
D:/rails/apps/cookbook/public/dispatch.cgi
[Tue Dec 06 09:35:56 2005] [error] [client 10.10.20.41] (OS 21)The
device is
not ready.  : couldn't create child process: 720021: dispatch.cgi
[Tue Dec 06 09:35:56 2005] [error] [client 10.10.20.41] (OS 21)The
device is
not ready.  : couldn't spawn child process:
D:/rails/apps/cookbook/public/dispatch.cgi

I am getting the message above.
What can I do?

Thanks

Frank
----- Original Message -----
From: "Steven Smith" <ssmith@fiveruns.com>
To: <rails@lists.rubyonrails.org>
Sent: Monday, December 05, 2005 10:29 PM
Subject: Re: [Rails] cookbook no running in production
998baab37c607466125c1235c1ad7006?d=identicon&s=25 Frank Rocco (frocco)
on 2005-12-06 15:47
(Received via mailing list)
Here is my apache config:

<VirtualHost *:8082>
 ServerName web.stemc.org
 DocumentRoot "d:/rails/apps/"
 RewriteEngine On

 RewriteCond %{REQUEST_URI} !^/cookbook/public
 RewriteRule ^/cookbook(/.*)?$   /cookbook/public$1
 <Directory "d:/rails/apps/cookbook/public/">
  Options ExecCGI FollowSymLinks
  AllowOverride all
  Allow from all
  Order allow,deny
  AddHandler cgi-script .cgi
  AddHandler fastcgi-script .fcgi
 </Directory>


</VirtualHost>

Thanks

Frank
998baab37c607466125c1235c1ad7006?d=identicon&s=25 Frank Rocco (frocco)
on 2005-12-06 16:03
(Received via mailing list)
I just tried to generate a scaffold Recipe Admin on the production box
and it seems that it cannot see the mysql database.

I get before updating scaffolding from your new schema,  try creating a
table for your model.
  ----- Original Message -----
  From: Frank
  To: rails@lists.rubyonrails.org
  Sent: Monday, December 05, 2005 2:48 PM
  Subject: [Rails] cookbook no running in production


  Hello,

  I have cookbook running on my pc, when I move it to our production
server, I get a page not found.

  If I just type http://web:8082/cookbook it brings up the welcome page.

  when I type http:web:8082/cookbook/categories
  it displays page not found

  I have mysql on both machines.
  I had to change the password in the cookbook config for the mysql
production server

  Any ideas what might be causing this?

  Thanks

  Frank


------------------------------------------------------------------------------


  _______________________________________________
  Rails mailing list
  Rails@lists.rubyonrails.org
  http://lists.rubyonrails.org/mailman/listinfo/rails
998baab37c607466125c1235c1ad7006?d=identicon&s=25 Frank Rocco (frocco)
on 2005-12-06 17:00
(Received via mailing list)
ok, I reinstalled mysql 5.0 and now I can connect.
I apps still refushes to run. getting fastcgi errors.

Thanks

Frank
  ----- Original Message -----
  From: Frank
  To: rails@lists.rubyonrails.org
  Sent: Monday, December 05, 2005 2:48 PM
  Subject: [Rails] cookbook no running in production


  Hello,

  I have cookbook running on my pc, when I move it to our production
server, I get a page not found.

  If I just type http://web:8082/cookbook it brings up the welcome page.

  when I type http:web:8082/cookbook/categories
  it displays page not found

  I have mysql on both machines.
  I had to change the password in the cookbook config for the mysql
production server

  Any ideas what might be causing this?

  Thanks

  Frank


------------------------------------------------------------------------------


  _______________________________________________
  Rails mailing list
  Rails@lists.rubyonrails.org
  http://lists.rubyonrails.org/mailman/listinfo/rails
998baab37c607466125c1235c1ad7006?d=identicon&s=25 Frank Rocco (frocco)
on 2005-12-06 17:33
(Received via mailing list)
Here is the latest message:

[Tue Dec 06 11:29:58 2005] [alert] [client 10.10.20.41] FastCGI: failed
to connect to (dynamic) server
"D:/rails/apps/receipts/public/dispatch.fcgi": something is seriously
wrong, any chance the socket/named_pipe directory was removed?, see the
FastCgiIpcDir directive
[Tue Dec 06 11:29:58 2005] [error] [client 10.10.20.41] FastCGI:
incomplete headers (0 bytes) received from server
"D:/rails/apps/receipts/public/dispatch.fcgi"
[Tue Dec 06 11:30:01 2005] [crit] (OS 3)The system cannot find the path
specified.  : FastCGI: can't start (dynamic) server
"D:/rails/apps/receipts/public/dispatch.fcgi": spawn_fs_process() failed
[Tue Dec 06 11:30:09 2005] [crit] (OS 3)The system cannot find the path
specified.  : FastCGI: can't start (dynamic) server
"D:/rails/apps/receipts/public/dispatch.fcgi": spawn_fs_process() failed
[Tue Dec 06 11:30:17 2005] [crit] (OS 3)The system cannot find the path
specified.  : FastCGI: can't start (dynamic) server
"D:/rails/apps/receipts/public/dispatch.fcgi": spawn_fs_process() failed
[Tue Dec 06 11:30:25 2005] [crit] (OS 3)The system cannot find the path
specified.  : FastCGI: can't start (dynamic) server
"D:/rails/apps/receipts/public/dispatch.fcgi": spawn_fs_process() failed

  ----- Original Message -----
  From: Frank
  To: rails@lists.rubyonrails.org
  Sent: Monday, December 05, 2005 2:48 PM
  Subject: [Rails] cookbook no running in production


  Hello,

  I have cookbook running on my pc, when I move it to our production
server, I get a page not found.

  If I just type http://web:8082/cookbook it brings up the welcome page.

  when I type http:web:8082/cookbook/categories
  it displays page not found

  I have mysql on both machines.
  I had to change the password in the cookbook config for the mysql
production server

  Any ideas what might be causing this?

  Thanks

  Frank


------------------------------------------------------------------------------


  _______________________________________________
  Rails mailing list
  Rails@lists.rubyonrails.org
  http://lists.rubyonrails.org/mailman/listinfo/rails
This topic is locked and can not be replied to.