Forum: Ruby FxRuby for Ruby 1.9.1 install issue

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
03346f950a31a8894c855a707b993379?d=identicon&s=25 Janos Sebok (Guest)
on 2009-05-18 10:37
(Received via mailing list)
Hi all.

I am new to FxRuby, and trying to install the toolkit.

I'm running winXP-Sp3

>ruby -v
ruby 1.9.1p0 (2009-01-30 revision 21907) [i386-mswin32]

>gem -v
1.3.3

>gem list

*** LOCAL GEMS ***

fxruby (1.6.19)
rubygems-update (1.3.3)

---
My problem is: require 'fox16' fails with a OS error message complaining
"Can not start application because msvcrt-ruby18.dll is not found".
After
closing the error window the console reads:

>ruby test.rb
test.rb:2:in `require': 126: Specified module not found.   -
d:/Ruby/Vm/1.9.1-p0/lib/ruby/
gems/1.9.1/gems/fxruby-1.6.19-x86-mswin32-60/ext/fox16/fox16.so
(LoadError)
        from test.rb:2:in `<main>'

fox16.so is present where it is looked for, but it is linking to
msvcrt-ruby18.dll.

Of course the 1.8 dll is not present. What may cause this? I remember to
have read FxRuby is Ruby 1.9 compatible for a while.

The very same gem works just fine on Ruby 1.8.7-p72.

Any help appreciated,
Thank you
--
Janos
E7cff3cfd41c495e1012227d7dc24202?d=identicon&s=25 Luis Lavena (luislavena)
on 2009-05-18 14:42
(Received via mailing list)
On May 18, 5:36 am, Janos Sebok <seb...@gmail.com> wrote:
> >gem -v
> ---
>
> fox16.so is present where it is looked for, but it is linking to
> msvcrt-ruby18.dll.
>
> Of course the 1.8 dll is not present. What may cause this? I remember to
> have read FxRuby is Ruby 1.9 compatible for a while.
>
> The very same gem works just fine on Ruby 1.8.7-p72.
>
> Any help appreciated,
> Thank you

You're trying to install a binary gem built for 1.8 on 1.9, which is
linking to the incorrect runtime library (as reported by the popup
message).

You will need to build the FOX gem from sources or will need a 1.9
provisioned gem.

I suggest contact the gem authors (mailing list or forums at
rubyforge) and ask for 1.9 version of the gem.

HTH,
03346f950a31a8894c855a707b993379?d=identicon&s=25 Janos Sebok (Guest)
on 2009-05-18 15:02
(Received via mailing list)
I was afraid it is the problem; although the toolkit and the bindind is
1.9
compatible, there is no gem created for 1.9.

I'll try and contact the author.

Is there a way to check for certified ruby version in the gem utility
when
installing a gem?

thanks,

Janos
03346f950a31a8894c855a707b993379?d=identicon&s=25 Janos Sebok (Guest)
on 2009-05-18 15:04
(Received via mailing list)
>I suggest contact the gem authors (mailing list or forums at
>rubyforge) and ask for 1.9 version of the gem.

I wrote to their ML yesterday, no response yet.
E7cff3cfd41c495e1012227d7dc24202?d=identicon&s=25 Luis Lavena (luislavena)
on 2009-05-19 01:11
(Received via mailing list)
On May 18, 10:01 am, Janos Sebok <seb...@gmail.com> wrote:
> [Note:  parts of this message were removed to make it a legal post.]
>
> I was afraid it is the problem; although the toolkit and the bindind is 1.9
> compatible, there is no gem created for 1.9.
>
> I'll try and contact the author.
>
> Is there a way to check for certified ruby version in the gem utility when
> installing a gem?
>

The need to build the gem and target "required_ruby_version", part of
the Gem::Specification
This topic is locked and can not be replied to.