FxRuby for Ruby 1.9.1 install issue


#1

Hi all.

I am new to FxRuby, and trying to install the toolkit.

I’m running winXP-Sp3

ruby -v
ruby 1.9.1p0 (2009-01-30 revision 21907) [i386-mswin32]

gem -v
1.3.3

gem list

*** LOCAL GEMS ***

fxruby (1.6.19)
rubygems-update (1.3.3)


My problem is: require ‘fox16’ fails with a OS error message complaining
“Can not start application because msvcrt-ruby18.dll is not found”.
After
closing the error window the console reads:

ruby test.rb
test.rb:2:in require': 126: Specified module not found. - d:/Ruby/Vm/1.9.1-p0/lib/ruby/ gems/1.9.1/gems/fxruby-1.6.19-x86-mswin32-60/ext/fox16/fox16.so (LoadError) from test.rb:2:in

fox16.so is present where it is looked for, but it is linking to
msvcrt-ruby18.dll.

Of course the 1.8 dll is not present. What may cause this? I remember to
have read FxRuby is Ruby 1.9 compatible for a while.

The very same gem works just fine on Ruby 1.8.7-p72.

Any help appreciated,
Thank you

Janos


#2

On May 18, 5:36 am, Janos S. removed_email_address@domain.invalid wrote:

gem -v


fox16.so is present where it is looked for, but it is linking to
msvcrt-ruby18.dll.

Of course the 1.8 dll is not present. What may cause this? I remember to
have read FxRuby is Ruby 1.9 compatible for a while.

The very same gem works just fine on Ruby 1.8.7-p72.

Any help appreciated,
Thank you

You’re trying to install a binary gem built for 1.8 on 1.9, which is
linking to the incorrect runtime library (as reported by the popup
message).

You will need to build the FOX gem from sources or will need a 1.9
provisioned gem.

I suggest contact the gem authors (mailing list or forums at
rubyforge) and ask for 1.9 version of the gem.

HTH,


#3

I was afraid it is the problem; although the toolkit and the bindind is
1.9
compatible, there is no gem created for 1.9.

I’ll try and contact the author.

Is there a way to check for certified ruby version in the gem utility
when
installing a gem?

thanks,

Janos


#4

I suggest contact the gem authors (mailing list or forums at
rubyforge) and ask for 1.9 version of the gem.

I wrote to their ML yesterday, no response yet.


#5

On May 18, 10:01 am, Janos S. removed_email_address@domain.invalid wrote:

[Note: parts of this message were removed to make it a legal post.]

I was afraid it is the problem; although the toolkit and the bindind is 1.9
compatible, there is no gem created for 1.9.

I’ll try and contact the author.

Is there a way to check for certified ruby version in the gem utility when
installing a gem?

The need to build the gem and target “required_ruby_version”, part of
the Gem::Specification