Forum: NGINX Compiling nginx 64-bit on opensolaris

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
96dfd0f0a8399d3b03feba1e6a562e0a?d=identicon&s=25 Edho P Arief (Guest)
on 2009-04-27 18:46
(Received via mailing list)
I've tried and unless I missed something, it doesn't look trivial.
Is there switch for amd64 somewhere in configure or environment
variables?

using

# CC="/opt/SSX0903/bin/cc -m64" ./configure --prefix=/usr/local/nginx

doesn't work immediately because it still uses x86 files
(ngx_sunpro_x86.*) when compiling. I manually 'fixed' by sed-ing
objs/Makefile, replacing all sunpro_x86 with sunpro_amd64 and later
renaming src/os/unix/ngx_sunpro_x86.map to
src/os/unix/ngx_sunpro_amd64.map

It then compiles and runs just fine (or so it looks like)
96dfd0f0a8399d3b03feba1e6a562e0a?d=identicon&s=25 Edho P Arief (Guest)
on 2009-04-27 18:46
(Received via mailing list)
On Mon, Apr 27, 2009 at 11:36 PM, Edho P Arief <edhoprima@gmail.com>
wrote:
> renaming src/os/unix/ngx_sunpro_x86.map to
> src/os/unix/ngx_sunpro_amd64.map
>
> It then compiles and runs just fine (or so it looks like)
>
>
> --
> O< ascii ribbon campaign - stop html mail - www.asciiribbon.org
>

by immediately I mean without additional environment variables / extra
setting when doing make
5640e332954fc0006aea97a155ce0afd?d=identicon&s=25 Igor Sysoev (Guest)
on 2009-04-28 08:26
(Received via mailing list)
On Mon, Apr 27, 2009 at 11:36:22PM +0700, Edho P Arief wrote:

> renaming src/os/unix/ngx_sunpro_x86.map to
> src/os/unix/ngx_sunpro_amd64.map
>
> It then compiles and runs just fine (or so it looks like)

Try ./configure --with-cpu-opt=amd64 ...
96dfd0f0a8399d3b03feba1e6a562e0a?d=identicon&s=25 Edho P Arief (Guest)
on 2009-04-28 14:58
(Received via mailing list)
2009/4/28 Igor Sysoev <is@rambler-co.ru>:
>> (ngx_sunpro_x86.*) when compiling. I manually 'fixed' by sed-ing
> Igor Sysoev
> http://sysoev.ru/en/
>
>

thanks. I've thought that is the parameter I need but not too sure
since it doesn't mention amd64.
This topic is locked and can not be replied to.