Compiling nginx 64-bit on opensolaris


#1

I’ve tried and unless I missed something, it doesn’t look trivial.
Is there switch for amd64 somewhere in configure or environment
variables?

using

CC="/opt/SSX0903/bin/cc -m64" ./configure --prefix=/usr/local/nginx

doesn’t work immediately because it still uses x86 files
(ngx_sunpro_x86.*) when compiling. I manually ‘fixed’ by sed-ing
objs/Makefile, replacing all sunpro_x86 with sunpro_amd64 and later
renaming src/os/unix/ngx_sunpro_x86.map to
src/os/unix/ngx_sunpro_amd64.map

It then compiles and runs just fine (or so it looks like)


#2

On Mon, Apr 27, 2009 at 11:36:22PM +0700, Edho P Arief wrote:

renaming src/os/unix/ngx_sunpro_x86.map to
src/os/unix/ngx_sunpro_amd64.map

It then compiles and runs just fine (or so it looks like)

Try ./configure --with-cpu-opt=amd64 …


#3

On Mon, Apr 27, 2009 at 11:36 PM, Edho P Arief removed_email_address@domain.invalid
wrote:

renaming src/os/unix/ngx_sunpro_x86.map to
src/os/unix/ngx_sunpro_amd64.map

It then compiles and runs just fine (or so it looks like)


O< ascii ribbon campaign - stop html mail - www.asciiribbon.org

by immediately I mean without additional environment variables / extra
setting when doing make


#4

2009/4/28 Igor S. removed_email_address@domain.invalid:

(ngx_sunpro_x86.*) when compiling. I manually ‘fixed’ by sed-ing
Igor S.
http://sysoev.ru/en/

thanks. I’ve thought that is the parameter I need but not too sure
since it doesn’t mention amd64.