Forum: Rails Germany script/generate scaffold klappt nicht

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Bd5b84161546e198eff8926db98410c5?d=identicon&s=25 Daniel Mechenbier (daniel79)
on 2009-04-11 02:25
Hi,

bin sowohl neu hier im Forum als auch in der Rails-Welt.
Habe mir heute das PDF "Agile Web Development with Rails" gekauft um das
mal durchzuarbeiten.

Auf Seite 76 (falls das PDF sonst noch wer hat) soll folgender Befehl
ausgeführt werden:

ruby script/generate scaffold product \ title:string description:text
image_url:string

Das funktioniert bis zur Zeile
exists public/stylesheets/

Dann kommt die Meldung
wrong number of arguments (1 for 2)

Kann mir da einer weiterhelfen?

P.S.: Auf Seite 71 wird der Befehl "rm -rf depot" benutzt. Bei mir kommt
die Meldung, das der Befehl "rm" entweder falsch geschrieben oder nicht
gefunden werden konnte?

Ist das mit Ruby immer alles so ein Glückspiel, ob Befehle funktionieren
oder nicht? Auf diesen ersten 70 oder 75 Seiten haben jetzt schon Gott
weiss wie viele Befehle überhaupt erst nicht funktioniert, ist irgendwie
ziemlich ernüchternd, dafür dass Ruby so cool sein soll...
0252d31b7ba34bc8328b4801c306ec23?d=identicon&s=25 Andree Wille (Guest)
on 2009-04-11 08:22
(Received via mailing list)
du arbeitest vermutlich mit windows, oder? die befehle die bei dir
nicht funktionieren sind unix/linux bzw mac befehle. du müßtest dir
die passenden befehle für windows heraussuchen.

GrüßeAndree
64502c61ed41ff9e917499a2347dd9fe?d=identicon&s=25 Werner Laude (Guest)
on 2009-04-11 10:03
(Received via mailing list)
Am 11.04.2009 um 02:25 schrieb Daniel Mb:


Hallo Daniel..

>
> Ist das mit Ruby immer alles so ein Glückspiel, ob Befehle
> funktionieren
> oder nicht? Auf diesen ersten 70 oder 75 Seiten haben jetzt schon Gott
> weiss wie viele Befehle überhaupt erst nicht funktioniert, ist
> irgendwie
> ziemlich ernüchternd, dafür dass Ruby so cool sein soll...


Ruby/Rails ist cool. Allerdings keine 3Klicks-Alles-Super Erfahrung.
Bischen Ausdauer (google ist dein Freund) und Frust Resistance sind
bestimmt bei jeder neuen Sprache erforderlich.

Hilfreich könnte die Verwendung einer IDE sein z.b. Netbeans (kostenlos)
Da gibt es auch Einführungsvideos.
Dann sollten auch die Scripte selbst unter M$ Vista oder so laufen..

Gruß und viel Erfolg


Werner Laude
newsgroup@wernerlaude.de
Cb37c4d3ed0c1eef295be9607347d2aa?d=identicon&s=25 Oliver Haag (Guest)
on 2009-04-11 13:14
(Received via mailing list)
Hallo Daniel,

wenn du ohne IDE arbeitest lauft "script/generate .." natürlich auch in
der windows-console. Du musst nur den Backslash "\" zwischen product und
title weglassen. Der ist im Buch drin, weil sie den Befehl über 2 Zeilen
geschrieben haben ..

Zu meinen Windows-Zeiten war http://aptana.com/rails eine gute IDE, die
mir den Einstieg erleichtert hat. Die free edition sollte reichen.

hope it helps
Oliver
Bd5b84161546e198eff8926db98410c5?d=identicon&s=25 Daniel Mechenbier (daniel79)
on 2009-04-11 16:19
Oliver Haag wrote:
> Hallo Daniel,
>
> wenn du ohne IDE arbeitest lauft "script/generate .." nat�rlich auch in
> der windows-console. Du musst nur den Backslash "\" zwischen product und
> title weglassen. Der ist im Buch drin, weil sie den Befehl �ber 2 Zeilen
> geschrieben haben ..
>
> Zu meinen Windows-Zeiten war http://aptana.com/rails eine gute IDE, die
> mir den Einstieg erleichtert hat. Die free edition sollte reichen.
>
> hope it helps
> Oliver

Super, danke für die Hilfe!
This topic is locked and can not be replied to.