Forum: Italian Ruby user group Problema gem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
6c1cd72f69a23298d812d25a50063fbe?d=identicon&s=25 Angelbit (Guest)
on 2009-04-07 16:02
(Received via mailing list)
Ciao

avevo installato gem con setup.rb tempo fa' su ubuntu ora provo a
utilizzarlo ma mi compare questo messaggio:/usr/bin/gem:10:Warning:
Gem::manage_gems is deprecated and will be removed on or after March
2009.

credo basti aggiornarlo ma non so' come...
Qualcuno conosce la soluzione? Grazie
B0f6d8efcf671ea3163449e231264cc4?d=identicon&s=25 Msan Msan (msan)
on 2009-04-07 17:53
(Received via mailing list)
2009/4/7 Angelbit <angelbit88@gmail.com>:
> Ciao
>
> avevo installato gem con setup.rb tempo fa' su ubuntu ora provo a
> utilizzarlo ma mi compare questo messaggio:/usr/bin/gem:10:Warning:
> Gem::manage_gems is deprecated and will be removed on or after March 2009.
>
> credo basti aggiornarlo ma non so' come...
> Qualcuno conosce la soluzione? Grazie

sudo gem update --system
6c1cd72f69a23298d812d25a50063fbe?d=identicon&s=25 Angelbit (Guest)
on 2009-04-07 17:59
(Received via mailing list)
Mauro ha scritto:
>>
>
> sudo gem update --system
> _______________________________________________
> Ml mailing list
> Ml@lists.ruby-it.org
> http://lists.ruby-it.org/mailman/listinfo/ml
>
stesso errore...
B0f6d8efcf671ea3163449e231264cc4?d=identicon&s=25 Msan Msan (msan)
on 2009-04-07 22:58
(Received via mailing list)
2009/4/7 Angelbit <angelbit88@gmail.com>:
>>> Qualcuno conosce la soluzione? Grazie
>>>
>>
>> sudo gem update --system
>> _______________________________________________
>> Ml mailing list
>> Ml@lists.ruby-it.org
>> http://lists.ruby-it.org/mailman/listinfo/ml
>>
> stesso errore...

Avevi scaricato l'ultimo tar.gz di rubygem da rubyforge?
Prova a riinstallare rubygem.
Scompatta il pacchetto entra sotto la directory creata e fai sudo ruby
setup.rb
6c1cd72f69a23298d812d25a50063fbe?d=identicon&s=25 Angelbit (Guest)
on 2009-04-08 20:31
(Received via mailing list)
nessun problema con i pacchetti che avevo installato tramite gem prima?

Mauro ha scritto:
6c1cd72f69a23298d812d25a50063fbe?d=identicon&s=25 Angelbit (Guest)
on 2009-04-10 02:22
(Received via mailing list)
Risolto, il problema stava che io usavo il comando "gem" che ubuntu
identificava con quello del suo repository (che avevo disinstallat tempo
fa)
mentre quello installato con setup.rb era "gem1.8" (me ne sono accorto
reinstallandolo e vedendo dove ha installato l'eseguibile)
Grazie per l'aiuto
Mauro ha scritto:
This topic is locked and can not be replied to.