Problema gem

Ciao

avevo installato gem con setup.rb tempo fa’ su ubuntu ora provo a
utilizzarlo ma mi compare questo messaggio:/usr/bin/gem:10:Warning:
Gem::manage_gems is deprecated and will be removed on or after March
2009.

credo basti aggiornarlo ma non so’ come…
Qualcuno conosce la soluzione? Grazie

2009/4/7 Angelbit [email protected]:

Ciao

avevo installato gem con setup.rb tempo fa’ su ubuntu ora provo a
utilizzarlo ma mi compare questo messaggio:/usr/bin/gem:10:Warning:
Gem::manage_gems is deprecated and will be removed on or after March 2009.

credo basti aggiornarlo ma non so’ come…
Qualcuno conosce la soluzione? Grazie

sudo gem update --system

Mauro ha scritto:

sudo gem update --system


Ml mailing list
[email protected]
http://lists.ruby-it.org/mailman/listinfo/ml

stesso errore…

2009/4/7 Angelbit [email protected]:

Qualcuno conosce la soluzione? Grazie

sudo gem update --system


Ml mailing list
[email protected]
http://lists.ruby-it.org/mailman/listinfo/ml

stesso errore…

Avevi scaricato l’ultimo tar.gz di rubygem da rubyforge?
Prova a riinstallare rubygem.
Scompatta il pacchetto entra sotto la directory creata e fai sudo ruby
setup.rb

nessun problema con i pacchetti che avevo installato tramite gem prima?

Mauro ha scritto:

Risolto, il problema stava che io usavo il comando “gem” che ubuntu
identificava con quello del suo repository (che avevo disinstallat tempo
fa)
mentre quello installato con setup.rb era “gem1.8” (me ne sono accorto
reinstallandolo e vedendo dove ha installato l’eseguibile)
Grazie per l’aiuto
Mauro ha scritto:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs