Forum: RSpec Problem with colorized output in cygwin on Vista (was: RSpec Formats with Strange Characters)

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
5d38ab152e1e3e219512a9859fcd93af?d=identicon&s=25 David Chelimsky (Guest)
on 2009-04-05 19:03
(Received via mailing list)
Changing the name of this to hopefully catch the eye of other
Vista/cygwin/rspec users.

On Sun, Apr 5, 2009 at 9:45 AM, Brandon Olivares
<programmer2188@gmail.com> wrote:
>> Please describe your environment. OS, various versions etc.
>>
>
> Ruby 1.8.7, RSpec 1.2.2, Cygwin on Windows Vista.

Those characters are for coloring the output. I'm running XP in
Parallels w/ ruby 1.8.7 and cygwin and I get colored output rather
than seeing those characters. I'm guessing Vista is different :)

Anybody else running Vista that knows how to get this to work?
F85bacbbd4814799d4526b3e35a431df?d=identicon&s=25 Brandon Olivares (Guest)
on 2009-04-05 22:11
(Received via mailing list)
Hi,

Well the output on the console works fine, it's when it is output to a
text
file when I see those characters.

Brandon
5d38ab152e1e3e219512a9859fcd93af?d=identicon&s=25 David Chelimsky (Guest)
on 2009-04-05 22:27
(Received via mailing list)
On Sun, Apr 5, 2009 at 12:58 PM, Brandon Olivares
<programmer2188@gmail.com> wrote:
> Hi,
>
> Well the output on the console works fine, it's when it is output to a text
> file when I see those characters.

Ah - well, in theory that shouldn't happen, because the colorizing
checks to see if it's printing to a console or not. So it sounds like
there is a bug related to your specific environment. Would you please
report that to http://rspec.lighthouseapp.com?

In the mean time, as a workaround, just exclude the --color option and
you should be fine.
Dded1a5d9e0bb7ffe6e5e55d24b7a983?d=identicon&s=25 Bernie (Guest)
on 2009-04-06 02:53
(Received via mailing list)
Brandon,
This was a tough one, although I still don't have color on autospec
(only have color when running specs manually ), AND I forgot exactly
how the problem was solved, but hopefully this will get you in the
right direction.

1. here are two gems that may help:
       gem install term-ansicolor
       gem install win32console
       and then for some reason I aded the following to my /cygdrive/c/
Users/<myusername>/irbrc file (I'm not sure if this is necessary for
running specs, but you may want to try it).
        require 'win32console'

2. finally installing and using the RXVT shell instead may have solved
the problem (again, I compleletely forgot)
    You can find it in the "Shells" section of the CYGWIN installer.
Here are the three checks I used:
    rxvt: VT102...
    rxvt-unicode-X: An improved...
    rxvt-unicode-common: An improved....

3. If you're doing a lot of work on IRB, you may want to also install
Wirble and add a few more lines to your irbrc:
    require 'wirble'
    Wirble.init
    Wirble.colorize

Wellp, hope this at least got you in the right direction...if you find
out how to colorize autospec, could you let me know?
Bernie
F85bacbbd4814799d4526b3e35a431df?d=identicon&s=25 Brandon Olivares (Guest)
on 2009-04-06 03:47
(Received via mailing list)
Hi,

Thanks. Installing term-ansicolor worked. The console still shows the
colors
and the text files do not have strange characters.

Brandon
F85bacbbd4814799d4526b3e35a431df?d=identicon&s=25 Brandon Olivares (Guest)
on 2009-04-06 04:03
(Received via mailing list)
Hi,

Nevermind that. I realized it works fine if I run rake spec, but not if
I
run script/autospec and only some of the examples run.

Brandon
This topic is locked and can not be replied to.