Problem with colorized output in cygwin on Vista (was: RSpec Formats with Strange Characters)


#1

Changing the name of this to hopefully catch the eye of other
Vista/cygwin/rspec users.

On Sun, Apr 5, 2009 at 9:45 AM, Brandon O.
removed_email_address@domain.invalid wrote:

Please describe your environment. OS, various versions etc.

Ruby 1.8.7, RSpec 1.2.2, Cygwin on Windows Vista.

Those characters are for coloring the output. I’m running XP in
Parallels w/ ruby 1.8.7 and cygwin and I get colored output rather
than seeing those characters. I’m guessing Vista is different :slight_smile:

Anybody else running Vista that knows how to get this to work?


#2

Hi,

Well the output on the console works fine, it’s when it is output to a
text
file when I see those characters.

Brandon


#3

On Sun, Apr 5, 2009 at 12:58 PM, Brandon O.
removed_email_address@domain.invalid wrote:

Hi,

Well the output on the console works fine, it’s when it is output to a text
file when I see those characters.

Ah - well, in theory that shouldn’t happen, because the colorizing
checks to see if it’s printing to a console or not. So it sounds like
there is a bug related to your specific environment. Would you please
report that to http://rspec.lighthouseapp.com?

In the mean time, as a workaround, just exclude the --color option and
you should be fine.


#4

Brandon,
This was a tough one, although I still don’t have color on autospec
(only have color when running specs manually ), AND I forgot exactly
how the problem was solved, but hopefully this will get you in the
right direction.

  1. here are two gems that may help:
    gem install term-ansicolor
    gem install win32console
    and then for some reason I aded the following to my /cygdrive/c/
    Users//irbrc file (I’m not sure if this is necessary for
    running specs, but you may want to try it).
    require ‘win32console’

  2. finally installing and using the RXVT shell instead may have solved
    the problem (again, I compleletely forgot)
    You can find it in the “Shells” section of the CYGWIN installer.
    Here are the three checks I used:
    rxvt: VT102…
    rxvt-unicode-X: An improved…
    rxvt-unicode-common: An improved…

  3. If you’re doing a lot of work on IRB, you may want to also install
    Wirble and add a few more lines to your irbrc:
    require ‘wirble’
    Wirble.init
    Wirble.colorize

Wellp, hope this at least got you in the right direction…if you find
out how to colorize autospec, could you let me know?
Bernie


#5

Hi,

Thanks. Installing term-ansicolor worked. The console still shows the
colors
and the text files do not have strange characters.

Brandon


#6

Hi,

Nevermind that. I realized it works fine if I run rake spec, but not if
I
run script/autospec and only some of the examples run.

Brandon