Forum: Rails France pb d'accès en localhost

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
38a45d59ba8a1510b4132572f7a66197?d=identicon&s=25 kim (Guest)
on 2009-02-05 16:01
(Received via mailing list)
Bonjour,
j'ai ce problème :
** Invoke db:sessions:create (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:sessions:create
rake aborted!
Access denied for user 'root'@'localhost' (using password: YES)

Je sais pas d'ou ça peut venir ... le user root est bien créer dans
mysql et
tout (j'ai mis exprès root pour être sur que ce soit pas un pb de
droit).
J'ai restful d'intaller, ça peut provenir de ça mais je vois pas comment
résoudre ce problème.

Cordialement
5183febd0dfb911f94c270ddd174fe71?d=identicon&s=25 guillaume belleguic (Guest)
on 2009-02-05 16:19
(Received via mailing list)
tu arrive à te connecter en tant que root à ta base mysql avec un outils
d'administration mysql ?


2009/2/5 kim <hklenoir@gmail.com>
38a45d59ba8a1510b4132572f7a66197?d=identicon&s=25 Kim HENOCQUE (Guest)
on 2009-02-05 17:19
(Received via mailing list)
Oui, je me connecte avec cet user sans problème via phpmyadmin.



guillaume belleguic a écrit :
E33fbbb8d778a5e2019138d680f23d68?d=identicon&s=25 Thomas (Guest)
on 2009-02-05 17:22
(Received via mailing list)
Mais sans password, non?

essaie dans la console

$ mysql -u root

pour voir

Kim HENOCQUE a écrit :
047a4fc673336a70a6b58338bc6d677d?d=identicon&s=25 Michel Belleville (Guest)
on 2009-02-05 17:27
(Received via mailing list)
Tu te connecte en mettant un mot de passe ?...

Michel Belleville


2009/2/5 Kim HENOCQUE <hklenoir@gmail.com>
38a45d59ba8a1510b4132572f7a66197?d=identicon&s=25 Kim HENOCQUE (Guest)
on 2009-02-05 17:33
(Received via mailing list)
Sisi ya un pass tout bête style 1234
et la commande

mysql -u root

donne

Access denied for user 'root'@'localhost' (using password: NO)

Cordialement


Thomas a écrit :
E33fbbb8d778a5e2019138d680f23d68?d=identicon&s=25 Thomas (Guest)
on 2009-02-05 17:36
(Received via mailing list)
Ok donc si tu fais:

$ mysql -u root -p
et que tu entres le mot de passe, tu te connectes?

si oui, tu as mis la même chose dans le database.yml de l'environnement
que tu utilises? (development je présume?)



Kim HENOCQUE a écrit :
A99870c1391c39da2089649745965bda?d=identicon&s=25 Jean-François Trân (Guest)
on 2009-02-05 17:43
(Received via mailing list)
Le 5 février 2009 16:01, Kim a écrit :

> j'ai ce problème :
> ** Invoke db:sessions:create (first_time)
> ** Invoke environment (first_time)
> ** Execute environment
> ** Execute db:sessions:create
> rake aborted!
> Access denied for user 'root'@'localhost' (using password: YES)

Essaie si ça marche avec : script/dbconsole et script/dbconsole -p

  -- Jean-François.

--
http://twitter.com/underflow_
38a45d59ba8a1510b4132572f7a66197?d=identicon&s=25 Kim HENOCQUE (Guest)
on 2009-02-05 17:57
(Received via mailing list)
Oui je me connecte avec le mot de passe et j'ai la mm chose dans mon
database.yml.
Je vois pas ce qu'il cloche ... c'est la 1er fois que j'ai ce problème.

Cordialement

Thomas a écrit :
98d4d4be867fc17d3120f683513d3819?d=identicon&s=25 Guillaume Betous (Guest)
on 2009-02-05 18:19
(Received via mailing list)
a tout hasard, poste ton database.yml il y a peut-etre une erreur à la
con
que tu vois plus

ou alors tu l'efface, t'en recrée un from scratch.

Le 5 février 2009 17:56, Kim HENOCQUE <hklenoir@gmail.com> a écrit :

> > $ mysql -u root -p
> >> et la commande
> >> Thomas a écrit :
> >>> Kim HENOCQUE a écrit :
> >>>>
> >>>>>     ** Invoke environment (first_time)
> >>>>>
> >>>>
> >
> >
> > >
> >
> >
>
>
> >
>


--
Pour la santé de votre ordinateur, préférez les logiciels libres.
Lire son mail : http://www.mozilla-europe.org/fr/products/thunderbird/
Browser le web : http://www.mozilla-europe.org/fr/products/firefox/
Suite bureautique : http://fr.openoffice.org/
5183febd0dfb911f94c270ddd174fe71?d=identicon&s=25 guillaume belleguic (Guest)
on 2009-02-05 18:21
(Received via mailing list)
sinon le "J'ai restful d'intaller" je ne comprend pas et ne vois pas
trop le
rapport ???

2009/2/5 Guillaume Betous <guillaume.betous@gmail.com>
A99870c1391c39da2089649745965bda?d=identicon&s=25 Jean-François Trân (Guest)
on 2009-02-05 18:26
(Received via mailing list)
Le 5 février 2009 18:20, Guillaume a écrit :
> sinon le "J'ai restful d'intaller" je ne comprend pas et ne vois pas trop le
> rapport ???

C'est comme la Roue de la Fortune, sauf que là faut proposer des
mots :

pour 100 points, je propose 'plugin'

(je tourne la roue)

pour 10 points, je propose 'le'

(je tourne la roue)

pour 50 points, je propose 'authentication'

Et je propose la solution à la phrase mystère :

"J'ai installé le plugin restful authentication"

     -- Jean-François.

à part ça, ça ne coûte rien de générer une appli Rails from
scratch et de vérifier si on arrive à créer une base et à faire
une migration "à la con".

--
http://twitter.com/underflow_
38a45d59ba8a1510b4132572f7a66197?d=identicon&s=25 kim (Guest)
on 2009-02-05 18:56
(Received via mailing list)
voici le database.yml

development:
  adapter: mysql
  encoding: utf8
  database: just4night_development
  username: root
  password: niark
  socket: /var/run/mysqld/mysqld.sock

test:
  adapter: mysql
  encoding: utf8
  database: just4night_test
  username: root
  password: niark
  socket: /var/run/mysqld/mysqld.sock

production:
  adapter: mysql
  encoding: utf8
  database: just4night_production
  username: root
  password: niark
  socket: /var/run/mysqld/mysqld.sock

J'ai bien sur créer une autre appli pour voir, ça marche nikel.
Création de la base de donnée et tout.
Comme j'ai quelques plugins d'installer, je me suis dit qu'il y avait
surement une relation de cause à effet.
Je démarre avec RoR, merci de votre aide.


Le 05/02/09, Jean-François Trân<jftran@rubyfrance.org> a écrit :
This topic is locked and can not be replied to.