Forum: Ruby on Rails Setting updated_at in database.

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Acb42a0e563bffaaf94ea2d07fbb1d8e?d=identicon&s=25 Tushar Gandhi (tushar_gandhi)
on 2009-02-02 11:19
Hi,
  I have an 'updated_at' field in events table. Whenever I am creating
an event it gets set to Time.now. But I don't want to set current time
in it. But I want to set another time. How should I do that? I tried
like this:-

event.updated_at="2008-02-02 03:35:11".
event.save

Still it not working.
Can anyone tell me how to do that?
Thanks,
Tushar
3131fcea0a711e5ad89c8d49cc9253b4?d=identicon&s=25 Julian Leviston (Guest)
on 2009-02-02 11:51
(Received via mailing list)
You can't without executing the sql directly, because updated at is
automagic

Sent from my iPhone

On 02/02/2009, at 9:19 PM, Tushar Gandhi
<rails-mailing-list@andreas-s.net
80e4cb97cae5c8d745f72337d93fd8f2?d=identicon&s=25 MaD (Guest)
on 2009-02-02 12:15
(Received via mailing list)
you can try overriding the method that is setting the updated_at
attribute. take a look at this (which is the first hit google found
for me on that subject):
http://neeraj.name/blog/articles/800-override-auto...
5772c599ccab3081e0fffb1d54f3b6de?d=identicon&s=25 Andrew Timberlake (andrewtimberlake)
on 2009-02-02 12:22
(Received via mailing list)
On Mon, Feb 2, 2009 at 12:19 PM, Tushar Gandhi <
rails-mailing-list@andreas-s.net> wrote:

> Still it not working.
> Can anyone tell me how to do that?
> Thanks,
> Tushar
> --
> Posted via http://www.ruby-forum.com/.
>
> >
>
Think about why you want to do this. The updated_at column is an
automatic
column that is meant to provide the date and time the entry was last
modified.
If you need to set a different date/time, why not create a new field
with a
new name and then set it manually or you can auto set it in a
before_save
method with your own business logic.

--
Andrew Timberlake
http://ramblingsonrails.com
http://www.linkedin.com/in/andrewtimberlake

"I have never let my schooling interfere with my education" - Mark Twain
Acb42a0e563bffaaf94ea2d07fbb1d8e?d=identicon&s=25 Tushar Gandhi (tushar_gandhi)
on 2009-02-02 12:58
MaD wrote:
> you can try overriding the method that is setting the updated_at
> attribute. take a look at this (which is the first hit google found
> for me on that subject):
> http://neeraj.name/blog/articles/800-override-auto...

That seems to be not working for me.

I have column name as "date_modified" instead of "updated_at".
I done everything that is given their.
This topic is locked and can not be replied to.