Setting updated_at in database


#1

Hi,
I have an ‘updated_at’ field in events table. Whenever I am creating
an event it gets set to Time.now. But I don’t want to set current time
in it. But I want to set another time. How should I do that? I tried
like this:-

event.updated_at=“2008-02-02 03:35:11”.
event.save

Still it not working.
Can anyone tell me how to do that?
Thanks,
Tushar


#2

You can’t without executing the sql directly, because updated at is
automagic

Sent from my iPhone

On 02/02/2009, at 9:19 PM, Tushar G.
<removed_email_address@domain.invalid


#3

you can try overriding the method that is setting the updated_at
attribute. take a look at this (which is the first hit google found
for me on that subject):
http://neeraj.name/blog/articles/800-override-automatic-timestamp-in-activerecrod-rails


#4

On Mon, Feb 2, 2009 at 12:19 PM, Tushar G. <
removed_email_address@domain.invalid> wrote:

Still it not working.
Can anyone tell me how to do that?
Thanks,
Tushar

Posted via http://www.ruby-forum.com/.

Think about why you want to do this. The updated_at column is an
automatic
column that is meant to provide the date and time the entry was last
modified.
If you need to set a different date/time, why not create a new field
with a
new name and then set it manually or you can auto set it in a
before_save
method with your own business logic.


Andrew T.
http://ramblingsonrails.com
http://www.linkedin.com/in/andrewtimberlake

“I have never let my schooling interfere with my education” - Mark Twain


#5

MaD wrote:

you can try overriding the method that is setting the updated_at
attribute. take a look at this (which is the first hit google found
for me on that subject):
http://neeraj.name/blog/articles/800-override-automatic-timestamp-in-activerecrod-rails

That seems to be not working for me.

I have column name as “date_modified” instead of “updated_at”.
I done everything that is given their.