Forum: Ruby on Rails Ruby 1.9.1 Windows rake tasks problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
7494efd9e38cf32e9b64d145ff8660bf?d=identicon&s=25 safestate (Guest)
on 2009-01-12 14:02
(Received via mailing list)
I can't get rake tasks to work properly using Ruby 1.9.1 with Windows

 I have set up all the gems for Rails 2.2.2, "rails myapp" works fine,
but when i rake db:migrate, it complains about rake tasks being
inaccessible

Ruby 1.8.7 works fine though.
9cf6e7f81d4339295b86e5fb7d7df49b?d=identicon&s=25 Vishwanath Nayak (nayak)
on 2009-01-12 14:38
(Received via mailing list)
Hi,

Did you run it with trace enabled (--trace)
Please share the error trace so that others can help you

NAYAK

On Mon, Jan 12, 2009 at 4:16 PM, safestate <safestate@gmail.com> wrote:

>
--
- NAYAK
7494efd9e38cf32e9b64d145ff8660bf?d=identicon&s=25 safestate (Guest)
on 2009-01-12 14:52
(Received via mailing list)
Ok thank you, i will do that.
7494efd9e38cf32e9b64d145ff8660bf?d=identicon&s=25 safestate (Guest)
on 2009-01-13 14:22
(Received via mailing list)
Hi

This time db:migrate did work, but then i got this error:


C:\Settings\user\My Documents\NetBeansProjects\urdu_words>c:
\Ruby-1.9.1\bin\ruby script/server
c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/activesupport-2.2.2/lib/
active_support/dependencies.rb:153:in `require': no such file to load
-- test
/unit/error (MissingSourceFile)
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in `block
in require'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/deprecation.rb:224:in `<top
(required)>'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in `block
in require'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support.rb:37:in `<top (required)>'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/rails-2.2.2/lib/
commands/server.rb:1:in `require'
        from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/rails-2.2.2/lib/
commands/server.rb:1:in `<top (required)>'
        from script/server:3:in `require'
        from script/server:3:in `<main>'


Any ideas on how to solve this one?
9a2a53db8e9b4476038c94a64b32833f?d=identicon&s=25 Ryan Bigg (ryan-bigg)
on 2009-02-01 01:31
(Received via mailing list)
Holy thread resurrection batman!

You need to be using edge rails.
This topic is locked and can not be replied to.