Ruby 1.9.1 Windows rake tasks problem


#1

I can’t get rake tasks to work properly using Ruby 1.9.1 with Windows

I have set up all the gems for Rails 2.2.2, “rails myapp” works fine,
but when i rake db:migrate, it complains about rake tasks being
inaccessible

Ruby 1.8.7 works fine though.


#2

Hi,

Did you run it with trace enabled (–trace)
Please share the error trace so that others can help you

NAYAK

On Mon, Jan 12, 2009 at 4:16 PM, safestate removed_email_address@domain.invalid wrote:

  • NAYAK

#3

Hi

This time db:migrate did work, but then i got this error:

C:\Settings\user\My Documents\NetBeansProjects\urdu_words>c:
\Ruby-1.9.1\bin\ruby script/server
c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/activesupport-2.2.2/lib/
active_support/dependencies.rb:153:in require': no such file to load -- test /unit/error (MissingSourceFile) from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:153:inblock
in require’
from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
new_constants_in' from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/deprecation.rb:224:in <top (required)>' from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:153:inrequire’
from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in block in require' from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/ activesupport-2.2.2/lib/active_support/dependencies.rb:521:innew_constants_in’
from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/
activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
require' from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/ activesupport-2.2.2/lib/active_support.rb:37:in<top (required)>’
from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/rails-2.2.2/lib/
commands/server.rb:1:in require' from c:/Ruby-1.9.1/lib/ruby/gems/1.9.1/gems/rails-2.2.2/lib/ commands/server.rb:1:in<top (required)>’
from script/server:3:in require' from script/server:3:in

Any ideas on how to solve this one?


#4

Holy thread resurrection batman!

You need to be using edge rails.


#5

Ok thank you, i will do that.