Forum: GNU Radio Question on Boost - could not detect the boost libraries (version 1.35 or higher)

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
4f23ce70930197295cbf054e998c79b9?d=identicon&s=25 Brook Lin (Guest)
on 2009-01-08 20:54
(Received via mailing list)
Hi All,

I am trying to install gnuradio from trunk (svn co
http://gnuradio.org/svn/gnuradio/trunk). Before that I download
boost_1_36_0
from boost.sourceforge.net, and install boost_1_36_0 first.

~$ cd boost_1_36_0/
~/boost_1_36_0$ BOOST_PREFIX=/opt/boost_1_36_0
~/boost_1_36_0$ ./configure --prefix=$BOOST_PREFIX
--with-libraries=thread,date_time,program_options
Building Boost.Jam with toolset gcc...
tools/jam/src/bin.linuxx86_64/bjam
Unicode/ICU support for Boost.Regex?... not found.
Backing up existing Boost.Build configuration in user-config.jam.1
Generating Boost.Build configuration in user-config.jam...
Generating Makefile...
~/boost_1_36_0$ make
./tools/jam/src/bin.linuxx86_64/bjam  --user-config=user-config.jam
--with-thread --with-date_time --with-program_options
warning: Graph library does not contain optional GraphML reader.
note: to enable GraphML support, set EXPAT_INCLUDE and EXPAT_LIBPATH to
the
note: directories containing the Expat headers and libraries,
respectively.
warning: skipping optional Message Passing Interface (MPI) library.
note: to enable MPI support, add "using mpi ;" to user-config.jam.
note: to suppress this message, pass "--without-mpi" to bjam.
note: otherwise, you can safely ignore this message.
Building Boost.Regex with the optional Unicode/ICU support disabled.
Please refer to the Boost.Regex documentation for more information
(don't panic: this is a strictly optional feature).
...patience...
...found 840 targets...
~/boost_1_36_0$ make install
...........
...skipped
<p/opt/boost_1_36_0/lib>libboost_program_options-gcc42-mt-1_36.so
for lack of /opt/boost_1_36_0/lib...
...skipped <p/opt/boost_1_36_0/lib>libboost_thread-gcc42-mt-1_36.so for
lack
of /opt/boost_1_36_0/lib...
...failed updating 1 target...
...skipped 7008 targets...
Not all Boost libraries built properly.

Then I tried to install from trunk.
svn co http://gnuradio.org/svn/gnuradio/trunk
cd trunk
export LD_LIBRARY_PATH=$BOOST_PREFIX/lib
./bootstrap
./configure --with-boost=$BOOST_PREFIX

However, I got error here.
configure: error: we could not detect the boost libraries (version 1.35
or
higher).
If you are sure you have boost installed, then check your version number
looking in <boost/version.hpp>.

Can anyone tell me how to correct it?

Appreciate,
Brook
--
View this message in context:
http://www.nabble.com/Question-on-Boost---could-no...
Sent from the GnuRadio mailing list archive at Nabble.com.
745d8202ef5a58c1058d0e5395a78f9c?d=identicon&s=25 Eric Blossom (Guest)
on 2009-01-08 21:11
(Received via mailing list)
On Thu, Jan 08, 2009 at 11:40:48AM -0800, Brook Lin wrote:
> warning: Graph library does not contain optional GraphML reader.
> ...found 840 targets...
> ~/boost_1_36_0$ make install
> ...........
> ...skipped <p/opt/boost_1_36_0/lib>libboost_program_options-gcc42-mt-1_36.so
> for lack of /opt/boost_1_36_0/lib...
> ...skipped <p/opt/boost_1_36_0/lib>libboost_thread-gcc42-mt-1_36.so for lack
> of /opt/boost_1_36_0/lib...
> ...failed updating 1 target...
> ...skipped 7008 targets...
> Not all Boost libraries built properly.

If you look at the first line of the output, it's probably saying
something like "Couldn't create /opt/boost_1_36_0 permission denied"

Try

  $ sudo make install

Eric
This topic is locked and can not be replied to.