Question on Boost - could not detect the boost libraries (version 1.35 or higher)


#1

Hi All,

I am trying to install gnuradio from trunk (svn co
http://gnuradio.org/svn/gnuradio/trunk). Before that I download
boost_1_36_0
from boost.sourceforge.net, and install boost_1_36_0 first.

~$ cd boost_1_36_0/
~/boost_1_36_0$ BOOST_PREFIX=/opt/boost_1_36_0
~/boost_1_36_0$ ./configure --prefix=$BOOST_PREFIX
–with-libraries=thread,date_time,program_options
Building Boost.Jam with toolset gcc…
tools/jam/src/bin.linuxx86_64/bjam
Unicode/ICU support for Boost.Regex?.. not found.
Backing up existing Boost.Build configuration in user-config.jam.1
Generating Boost.Build configuration in user-config.jam…
Generating Makefile…
~/boost_1_36_0$ make
./tools/jam/src/bin.linuxx86_64/bjam --user-config=user-config.jam
–with-thread --with-date_time --with-program_options
warning: Graph library does not contain optional GraphML reader.
note: to enable GraphML support, set EXPAT_INCLUDE and EXPAT_LIBPATH to
the
note: directories containing the Expat headers and libraries,
respectively.
warning: skipping optional Message Passing Interface (MPI) library.
note: to enable MPI support, add “using mpi ;” to user-config.jam.
note: to suppress this message, pass “–without-mpi” to bjam.
note: otherwise, you can safely ignore this message.
Building Boost.Regex with the optional Unicode/ICU support disabled.
Please refer to the Boost.Regex documentation for more information
(don’t panic: this is a strictly optional feature).
…patience…
…found 840 targets…
~/boost_1_36_0$ make install

…skipped
<p/opt/boost_1_36_0/lib>libboost_program_options-gcc42-mt-1_36.so
for lack of /opt/boost_1_36_0/lib…
…skipped <p/opt/boost_1_36_0/lib>libboost_thread-gcc42-mt-1_36.so for
lack
of /opt/boost_1_36_0/lib…
…failed updating 1 target…
…skipped 7008 targets…
Not all Boost libraries built properly.

Then I tried to install from trunk.
svn co http://gnuradio.org/svn/gnuradio/trunk
cd trunk
export LD_LIBRARY_PATH=$BOOST_PREFIX/lib
./bootstrap
./configure --with-boost=$BOOST_PREFIX

However, I got error here.
configure: error: we could not detect the boost libraries (version 1.35
or
higher).
If you are sure you have boost installed, then check your version number
looking in <boost/version.hpp>.

Can anyone tell me how to correct it?

Appreciate,
Brook

View this message in context:
http://www.nabble.com/Question-on-Boost---could-not-detect-the-boost-libraries-(version-1.35-or-higher)-tp21359412p21359412.html
Sent from the GnuRadio mailing list archive at Nabble.com.


#2

On Thu, Jan 08, 2009 at 11:40:48AM -0800, Brook L. wrote:

warning: Graph library does not contain optional GraphML reader.
…found 840 targets…
~/boost_1_36_0$ make install

…skipped <p/opt/boost_1_36_0/lib>libboost_program_options-gcc42-mt-1_36.so
for lack of /opt/boost_1_36_0/lib…
…skipped <p/opt/boost_1_36_0/lib>libboost_thread-gcc42-mt-1_36.so for lack
of /opt/boost_1_36_0/lib…
…failed updating 1 target…
…skipped 7008 targets…
Not all Boost libraries built properly.

If you look at the first line of the output, it’s probably saying
something like “Couldn’t create /opt/boost_1_36_0 permission denied”

Try

$ sudo make install

Eric