Forum: Ruby on Rails Cannot rake my gems

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
7eb90c651607f9b63ff3769923677d08?d=identicon&s=25 Caps Lock (capslock118)
on 2008-11-14 01:33

Hi,

So in a recently previous post I explained I am having an issue that I
believe is due to the application being upgraded to 2.1 from 2.0.1

To minimize headaches I thought freezing gems would be a grandios
idea.....

however I recieve this error and I am finding little information on the
web about it.


Code :

   1. webuser@server:/var/www/$ rake rails:freeze:gems
   2. (in /var/www/gdc)
   3. rake aborted!
   4. undefined method `version' for nil:NilClass
   5.
   6. (See full trace by running task with --trace)
   7. webuser@server:/var/www/$

Does anyone know the issue?


I read that it is possible my gems might be out of date or rake might
be, so i try to update gems but I get a 'Killed' message with no sign of
a successful update.

Thank you for any knowledge you could provide.
D69d23d8e811e8ab2a8593380d6ede63?d=identicon&s=25 Jeff Emminger (jemminger)
on 2008-11-14 16:42
(Received via mailing list)
try again with

  rake --trace rails:freeze:gems

to get a more descriptive error trace


On Nov 13, 7:33 pm, Caps Lock <rails-mailing-l...@andreas-s.net>
This topic is locked and can not be replied to.