Forum: Ruby `require': no such file to load -- win32/sound

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
unknown (Guest)
on 2008-10-07 15:35
(Received via mailing list)
I am trying out the following X10 intergratuion with Bamboo  (http://
urlant.com//yvwjlo) and when i installed the one click windows install
of Ruby and run the ruby script, i get the following error:

C:\ruby\bin>ruby C:\ruby\samples\ContinuousIntegrationLampControl
\continuous_bui
lder_lamp_controller.rb
C:/ruby/samples/ContinuousIntegrationLampControl/
continuous_builder_lamp_control
ler.rb:3:in `require': no such file to load -- win32/sound (LoadError)
        from C:/ruby/samples/ContinuousIntegrationLampControl/
continuous_builder
_lamp_controller.rb:3

Is there any 101 testing i can do to test that ruby is working
correctly befiore i go to far into hacking the script.

Ww
Daniel Berger (Guest)
on 2008-10-07 15:53
(Received via mailing list)
On Oct 7, 7:33 am, mediastor...@googlemail.com wrote:
>         from C:/ruby/samples/ContinuousIntegrationLampControl/
> continuous_builder
> _lamp_controller.rb:3
>
> Is there any 101 testing i can do to test that ruby is working
> correctly befiore i go to far into hacking the script.

Fire up an irb session and type 'require "win32/sound"'.

If that fails, try 'require "rubygems"' first, then try to load win32-
sound. If that works, you either need to set your RUBYOPT environment
variable, or you need to explicitly require rubygems first.

If that doesn't work, then type "gem list" and make sure you have
win32-sound installed.

Regards,

Dan
This topic is locked and can not be replied to.