Forum: Ruby on Rails Exception on rails: uninitialized constant Base

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Bcaab3a589467355171b89210f2e4e76?d=identicon&s=25 Breno Leitao (leitao)
on 2005-11-25 01:05
Hello,

I have installed ROR and when I try to create a project, i am getting a
Exception,  that don't make me any sense.

I have installed it from gem, and ruby from apt Ubuntu repository. Do
anyone have any idea? I have ever installed libfcgi, and nothing
different.

Thanks,
Breno Leitão

--

leitao@capitu:~/rails$ rails foo
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3.2969/lib/active_support/dependencies.rb:200:in
`const_missing': uninitialized constant Base (NameError)
        from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.11.0.2969/lib/action_view.rb:30
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__'
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `require'
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3.2969/lib/active_support/dependencies.rb:214:in
`require'
        from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.11.0.2969/lib/action_controller.rb:58
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__'
        from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in `require'
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3.2969/lib/active_support/dependencies.rb:214:in
`require'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:182:in `activate'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:181:in `each'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:181:in `activate'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:167:in `activate'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:166:in `each'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:166:in `activate'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:37:in
`require_gem_with_options'
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:31:in
`require_gem'
        from /usr/bin/rails:17
Bcaab3a589467355171b89210f2e4e76?d=identicon&s=25 Breno Leitao (leitao)
on 2005-11-25 01:18
I've noticed some issue with Debian and Rails:
Anyone interessed should look at
http://wiki.rubyonrails.com/rails/pages/RailsOnDeb...


[]'s
Breno Leitão
Bcaab3a589467355171b89210f2e4e76?d=identicon&s=25 Breno Leitao (leitao)
on 2005-11-25 01:22
Now i got a much better error message:

    Rails requires Ruby version 1.8.2 (2004-12-25) or later.
    You're running 1.8.2 (2004-12-23); please upgrade to continue.


Found the error.

[]'s
Breno Leitão
1e99128ebac5ca41c91940291d315332?d=identicon&s=25 contact (Guest)
on 2005-11-25 02:23
(Received via mailing list)
The version of Ruby in Ubuntu Hoary was 2 days short of the final
release.

Perhaps you should try upgrading to Breezy?

Luke
This topic is locked and can not be replied to.