Exception on rails: uninitialized constant Base


#1

Hello,

I have installed ROR and when I try to create a project, i am getting a
Exception, that don’t make me any sense.

I have installed it from gem, and ruby from apt Ubuntu repository. Do
anyone have any idea? I have ever installed libfcgi, and nothing
different.

Thanks,
Breno Leitão

leitao@capitu:~/rails$ rails foo
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3.2969/lib/active_support/dependencies.rb:200:in
const_missing': uninitialized constant Base (NameError) from /usr/lib/ruby/gems/1.8/gems/actionpack-1.11.0.2969/lib/action_view.rb:30 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire__’
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in require' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3.2969/lib/active_support/dependencies.rb:214:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/actionpack-1.11.0.2969/lib/action_controller.rb:58
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.3.2969/lib/active_support/dependencies.rb:214:in
require' from /usr/local/lib/site_ruby/1.8/rubygems.rb:182:inactivate’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:181:in each' from /usr/local/lib/site_ruby/1.8/rubygems.rb:181:inactivate’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:167:in activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:166:ineach’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:166:in activate' from /usr/local/lib/site_ruby/1.8/rubygems.rb:37:inrequire_gem_with_options’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:31:in
`require_gem’
from /usr/bin/rails:17


#2

I’ve noticed some issue with Debian and Rails:
Anyone interessed should look at
http://wiki.rubyonrails.com/rails/pages/RailsOnDebianUnstable

[]'s
Breno Leitão


#3

Now i got a much better error message:

Rails requires Ruby version 1.8.2 (2004-12-25) or later.
You're running 1.8.2 (2004-12-23); please upgrade to continue.

Found the error.

[]'s
Breno Leitão


#4

The version of Ruby in Ubuntu Hoary was 2 days short of the final
release.

Perhaps you should try upgrading to Breezy?

Luke