Forum: Rails Engines WEBrick won't start getting require_frameworks runtime error

3782d6d16cf30933f2246447ecc938d5?d=identicon&s=25 Amit Kumar (amitkumar)
on 2007-12-27 14:39
Hi

WEBrick won't start and getting the following error-
 jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in
`require_frameworks': Could not find RubyGem jruby-openssl (>= 0.0.0)
(RuntimeError)

        from
/mnt/slash/home/.../jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:156:in
`process'
        from
/mnt/slash/home/.../jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:in
`run'
        from /mnt/slash/home/../bookstore/config/environment.rb:13:in
`run'
        from /mnt/slash/home/.../bookstore/config/environment.rb:13:in
`require'
        from
/mnt/slash/home/../jruby-1.1b1/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from
/mnt/slash/home/.../jruby-1.1b1/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:in
`require'
        from
/mnt/slash/home/../jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/servers/webrick.rb:59:in
`new_constants_in'
        from
/mnt/slash/home/../jruby-1.1b1/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:in
`require'
         ... 7 levels...
        from
/mnt/slash/home/../jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/server.rb:38:in
`require'
        from
/mnt/slash/home/../jruby-1.1b1/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from script/server:3:in `require'

using the jruby-1.1b1 and rails version 2.0.2 , can anyone guide me what
should i do to resolve this issue so the server start up and running
fine , i am afraid with this Jruby stuff and i am the just a beginner
:-)
B55f64c8b622b654866b286907a0cdf7?d=identicon&s=25 Chris Lee (clee)
on 2008-01-17 05:02
Amit Kumar wrote:
> Hi
>
> WEBrick won't start and getting the following error-
>  jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in
> `require_frameworks': Could not find RubyGem jruby-openssl (>= 0.0.0)
> (RuntimeError)
>
> using the jruby-1.1b1 and rails version 2.0.2 , can anyone guide me what
> should i do to resolve this issue so the server start up and running
> fine , i am afraid with this Jruby stuff and i am the just a beginner
> :-)

I need help with this also. I first got openssl error, so i apt-get
install all the openssl stuff i could find. I now get this error, and I
would also like to know why the error is coming up like this (ie
something wrong with my install?), and what the workaround is.

Thanks
4784e3f13c0f9a087ae8ed803f5f8b5c?d=identicon&s=25 Juncle Juncle (juncle)
on 2008-01-30 06:15
Hi -

I had the same issue under Ubuntu 7.10 - I found this article
http://www.searchmarked.com/ubuntu/install-ruby-on...

and ran
sudo apt-get install libopenssl-ruby

and the issue went away

j
This topic is locked and can not be replied to.