WEBrick won't start getting require_frameworks runtime error


#1

Hi

WEBrick won’t start and getting the following error-
jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in
`require_frameworks’: Could not find RubyGem jruby-openssl (>= 0.0.0)
(RuntimeError)

    from

/mnt/slash/home/…/jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:156:in
process' from /mnt/slash/home/.../jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:49:inrun’
from /mnt/slash/home/…/bookstore/config/environment.rb:13:in
run' from /mnt/slash/home/.../bookstore/config/environment.rb:13:inrequire’
from
/mnt/slash/home/…/jruby-1.1b1/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
require' from /mnt/slash/home/.../jruby-1.1b1/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:inrequire’
from
/mnt/slash/home/…/jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/servers/webrick.rb:59:in
new_constants_in' from /mnt/slash/home/../jruby-1.1b1/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:inrequire’
… 7 levels…
from
/mnt/slash/home/…/jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/server.rb:38:in
require' from /mnt/slash/home/../jruby-1.1b1/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from script/server:3:in `require’

using the jruby-1.1b1 and rails version 2.0.2 , can anyone guide me what
should i do to resolve this issue so the server start up and running
fine , i am afraid with this Jruby stuff and i am the just a beginner
:slight_smile:


#2

Amit K. wrote:

Hi

WEBrick won’t start and getting the following error-
jruby-1.1b1/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/initializer.rb:159:in
`require_frameworks’: Could not find RubyGem jruby-openssl (>= 0.0.0)
(RuntimeError)

using the jruby-1.1b1 and rails version 2.0.2 , can anyone guide me what
should i do to resolve this issue so the server start up and running
fine , i am afraid with this Jruby stuff and i am the just a beginner
:slight_smile:

I need help with this also. I first got openssl error, so i apt-get
install all the openssl stuff i could find. I now get this error, and I
would also like to know why the error is coming up like this (ie
something wrong with my install?), and what the workaround is.

Thanks


#3

Hi -

I had the same issue under Ubuntu 7.10 - I found this article
http://www.searchmarked.com/ubuntu/install-ruby-on-rails-in-ubuntu.php

and ran
sudo apt-get install libopenssl-ruby

and the issue went away

j