Forum: Ruby on Rails can't activate activesupport (= 1.0.4), already activated...

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
07b9a33337e750392b2ecb7acc0ac26a?d=identicon&s=25 Matt (Guest)
on 2007-06-26 08:54
I'm encountering a problem when trying to go through the Rails4Days
tutorial: As
the guide suggests I have downloaded the version of rails that is being
used in the tutorial with gem and have specified the versions in

# Include your application configuration below
# Require Rails libraries.
require 'rubygems'
gem 'activesupport', '= 1.0.4'
gem 'activerecord', '= 1.10.1'
gem 'actionpack', '= 1.8.1'
gem 'actionmailer', '= 0.9.1'
gem 'actionwebservice', '= 0.7.1'
gem 'rails', '= 0.12.1'

When I try to execute the following command:

$ script/generate model category exists app/models/ exists test/unit/
exists test/fixtures/ create app/models/category.rb create
test/unit/category_test.rb create test/fixtures/categories.yml

I receive this error:

/usr/local/lib/site_ruby/1.8/rubygems.rb:246:in `activate': can't
activate activesupport (= 1.0.4), already activated activesupport-1.4.2]
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:76:in
        from /usr/local/lib/site_ruby/1.8/rubygems.rb:50:in `gem'
        from ./script/../config/../config/environment.rb:64
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
        from script/generate:3

I've tried searching google without success. Any suggestions would be
very much appreciated as I would love to complete this tutorial.
07b9a33337e750392b2ecb7acc0ac26a?d=identicon&s=25 Matt (Guest)
on 2007-06-27 11:02
C4b929d5f7755cd93f362f424c6c3852?d=identicon&s=25 (Guest)
on 2007-12-05 19:26
(Received via mailing list)
did you ever get an answer for this?

I'm having the same problem, however mines realted to not being able
to activate activerecord.  This only appeared after I installed the
release candidate 1.99.1 of rails.
This topic is locked and can not be replied to.