Can't activate activesupport (= 1.0.4), already activated

I’m encountering a problem when trying to go through the Rails4Days
tutorial: http://www.rails4days.pwp.blueyonder.co.uk/Rails4Days.pdf. As
the guide suggests I have downloaded the version of rails that is being
used in the tutorial with gem and have specified the versions in
/config/environment.rb:

Include your application configuration below

Require Rails libraries.

require ‘rubygems’
gem ‘activesupport’, ‘= 1.0.4’
gem ‘activerecord’, ‘= 1.10.1’
gem ‘actionpack’, ‘= 1.8.1’
gem ‘actionmailer’, ‘= 0.9.1’
gem ‘actionwebservice’, ‘= 0.7.1’
gem ‘rails’, ‘= 0.12.1’

When I try to execute the following command:

$ script/generate model category exists app/models/ exists test/unit/
exists test/fixtures/ create app/models/category.rb create
test/unit/category_test.rb create test/fixtures/categories.yml

I receive this error:

/usr/local/lib/site_ruby/1.8/rubygems.rb:246:in activate': can't activate activesupport (= 1.0.4), already activated activesupport-1.4.2] (Gem::Exception) from /usr/local/lib/site_ruby/1.8/rubygems.rb:76:inactive_gem_with_options’
from /usr/local/lib/site_ruby/1.8/rubygems.rb:50:in gem' from ./script/../config/../config/environment.rb:64 from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
from
/usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/commands/generate.rb:1
from
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require’
from script/generate:3

I’ve tried searching google without success. Any suggestions would be
very much appreciated as I would love to complete this tutorial.

bump

did you ever get an answer for this?

I’m having the same problem, however mines realted to not being able
to activate activerecord. This only appeared after I installed the
release candidate 1.99.1 of rails.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs