Forum: Ruby on Rails Mongrel not starting

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
24c539689cd95ef54ed10234957d6fc1?d=identicon&s=25 Ike (Guest)
on 2007-06-17 03:15
(Received via mailing list)
Uh oh...I made NO changes to any of my files. Yet, from within Instant
Rails, when I go to Configure - Rails Application, check my
application then press "Start with Mongrel" I get:

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment....

And then the Dos window disappears, and my rails app never starts.
Ugh...anyone have any idea where I can even start looking for whats
wrong here? Thanks, rv
588ab1c0a5610a7e160a3b101abb91e6?d=identicon&s=25 MichaelLatta (Guest)
on 2007-06-17 03:54
(Received via mailing list)
Is there anything in your log file?  It sounds like mongrel is
crashing.  Are you using any C gems beyond those that come with Ruby?
I have not used instant Rails.  Can you try starting mongrel from the
command line so the window stays open even if the process crashes?

Michael
24c539689cd95ef54ed10234957d6fc1?d=identicon&s=25 Ike (Guest)
on 2007-06-17 13:52
(Received via mailing list)
I see in \rails_apps\myapp\loga\mongrel_debug\ files.log it says:

FILES OPEN AT EXIT

I dont have a clue what this means or how to resolve it? Any ideas?
2b891e820c238ded365d035771603f21?d=identicon&s=25 Bill Walton (Guest)
on 2007-06-17 16:36
(Received via mailing list)
Hi Ike,

Ike wrote:

> Uh oh...I made NO changes to any of my files.

Not sure what you mean by this.  Does you mean that mongrel *was*
runnable
before but now it's not?  Or that you just unzipped InstantRails, didn't
change anything, etc.?

> Yet, from within Instant Rails, when I go to Configure -
> Rails Application, check my application then press "Start
> with Mongrel" I get:
>
> ** Starting Mongrel listening at 0.0.0.0:3000
> ** Starting Rails with development environment....
>
> And then the Dos window disappears, and my rails app never
> starts.  Ugh...anyone have any idea where I can even start looking
> for whats wrong here? Thanks, rv

This behavior is often seen when mongrel is started on a port that's
already
in use by another process.  Open a command window and run 'netstat -a'.
That will give you a list of all the ports in use and the processes
using
them.  If you see port 3000 being used, that's the problem.  Easiest
thing
to do is start mongrel on a different, unused port.

hth,
Bill
This topic is locked and can not be replied to.