Mongrel not starting


#1

Uh oh…I made NO changes to any of my files. Yet, from within Instant
Rails, when I go to Configure - Rails Application, check my
application then press “Start with Mongrel” I get:

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…

And then the Dos window disappears, and my rails app never starts.
Ugh…anyone have any idea where I can even start looking for whats
wrong here? Thanks, rv


#2

Is there anything in your log file? It sounds like mongrel is
crashing. Are you using any C gems beyond those that come with Ruby?
I have not used instant Rails. Can you try starting mongrel from the
command line so the window stays open even if the process crashes?

Michael


#3

I see in \rails_apps\myapp\loga\mongrel_debug\ files.log it says:

FILES OPEN AT EXIT

I dont have a clue what this means or how to resolve it? Any ideas?


#4

Hi Ike,

Ike wrote:

Uh oh…I made NO changes to any of my files.

Not sure what you mean by this. Does you mean that mongrel was
runnable
before but now it’s not? Or that you just unzipped InstantRails, didn’t
change anything, etc.?

Yet, from within Instant Rails, when I go to Configure -
Rails Application, check my application then press “Start
with Mongrel” I get:

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…

And then the Dos window disappears, and my rails app never
starts. Ugh…anyone have any idea where I can even start looking
for whats wrong here? Thanks, rv

This behavior is often seen when mongrel is started on a port that’s
already
in use by another process. Open a command window and run ‘netstat -a’.
That will give you a list of all the ports in use and the processes
using
them. If you see port 3000 being used, that’s the problem. Easiest
thing
to do is start mongrel on a different, unused port.

hth,
Bill