Forum: Ruby on Rails Database Sessions with Oracle 10g Problem

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
E4afe00726a6db914982c25c4c91fde8?d=identicon&s=25 SteveG (Guest)
on 2007-05-04 04:26
(Received via mailing list)
Hello all,

I changed the app to use the active_record_store for sessions. This
worked fine in my Windows development environment. Then I moved the
app over to the Linux Dev environment and now I am seeing oracle
ORA-24812 errors as soon as I access the app. The WIndows and Linux
environments point to the same database. The linux box is using a
oracle full client although, since I did not install it, I do not know
the exact one.

Any ideas? Any help is appreciated


Error from log:
May 03 21:17:03 appd01 rails[14929]: OCIError (Error while trying to
retrieve text for error ORA-24812):    /usr/local/lib/ruby/site_ruby/
1.8/oci8.rb:837:in `write'    /usr/local/lib/ruby/site_ruby/1.8/
oci8.rb:837:in `write'    /vendor/rails/activerecord/lib/active_record/
connection_adapters/oracle_adapter.rb:56:in `write_lobs'    /vendor/
oracle_adapter.rb:49:in `each'    /vendor/rails/activerecord/lib/
`write_lobs'    /vendor/rails/activerecord/lib/active_record/
callbacks.rb:333:in `send'    /vendor/rails/activerecord/lib/
active_record/callbacks.rb:333:in `callback'    /vendor/rails/
activerecord/lib/active_record/callbacks.rb:330:in `each'    /vendor/
`callback'    /vendor/rails/activerecord/lib/active_record/
callbacks.rb:243:in `create_or_update'    /vendor/rails/activerecord/
lib/active_record/base.rb:1546:in `save_without_validation'    /vendor/
`save_without_transactions'    /vendor/rails/activerecord/lib/
active_record/transactions.rb:129:in `save'    /vendor/rails/
database_statements.rb:59:in `transaction'    /vendor/rails/
activerecord/lib/active_record/transactions.rb:95:in `transaction'    /
`transaction'    /vendor/rails/activerecord/lib/active_record/
transactions.rb:129:in `save'    /vendor/rails/actionpack/lib/
action_controller/session/active_record_store.rb:309:in `update'    /
`silence'    /vendor/rails/actionpack/lib/action_controller/session/
active_record_store.rb:309:in `update'    /vendor/rails/actionpack/lib/
E4afe00726a6db914982c25c4c91fde8?d=identicon&s=25 SteveG (Guest)
on 2007-05-04 18:20
(Received via mailing list)
Hello. I figured out what the issue was. The ORACLE_HOME and
LD_LIBRARY_PATH env variables were not being set. The application
worked fine if I started mongrel manually locally on the box since the
variables are in the bash_profile. The application fails if I used cap
to start/restart mongrel. The weird thing is the whole app worked fine
until I told it to start using the active record store for sessions. I
guess it was a problem with using CLOB datatypes.

I used the following solution:

I also found a couple more if that one does not work for you:
This topic is locked and can not be replied to.