Forum: Ruby on Rails no route found to match "/cookbook/recipe/list" with {:metho

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
95ca6c17d86c6b4a9ae57d3ed97b35d1?d=identicon&s=25 VolteFace (Guest)
on 2007-03-18 18:53
(Received via mailing list)
Hi,

I ve just spent about three hours trying to figure this out, so any
help would be appreciated.

I ve followed these steps:

1. Downloaded Instant Rails
2. Unzipped it
3. Ran "InstantRails.exe" to configure it. (path is c:\InstantRails)
4. Went to the "Manage Rails Applications" area and chose "cookbook"
app.
5. Clicked on "Start with Mongrel"
6. Mongrel was started and app was loaded on port 3001.
7. I opened a browser and typed "http://localhost:3000/cookbook/recipe/
list"

And I get this message:
"no route found to match "/cookbook/recipe/list" with {:method=>:get}"

Am I doing something wrong here? I appreciate your help very much.
254513687a01330ba0ae676538de459b?d=identicon&s=25 Ravil Bayramgalin (ral)
on 2007-03-18 19:31
I would advise you to try to type http://localhost:3000/recipe/list on
step 7, because u already launched project cookbook and there is next
rule for ruby on rails:
http://"server"/"controller"/"method"...
for u: server - localhost, controller - recipe and method - list
95ca6c17d86c6b4a9ae57d3ed97b35d1?d=identicon&s=25 VolteFace (Guest)
on 2007-03-18 19:39
(Received via mailing list)
Thanks a bunch, Ravil.

Your suggestion fixed it.






On Mar 18, 2:31 pm, Ravil Bayramgalin <rails-mailing-l...@andreas-
531eb73f8fbf05a197721d02b4e6aadb?d=identicon&s=25 Bogdan Ionescu (Guest)
on 2007-03-19 00:37
(Received via mailing list)
I'm not familiar with instant rails, but wouldn't you want to use port
3001
if your app was started on that port?
C475cffda1800fbc3f3af17bc10c220f?d=identicon&s=25 Curt Hibbs (Guest)
on 2007-03-19 03:29
(Received via mailing list)
On 3/18/07, VolteFace <nandan_n@hotmail.com> wrote:
> 2. Unzipped it
>
> Am I doing something wrong here? I appreciate your help very much.


Browse to http://localhost:3001/cookbook/recipe/ and it should work.

Curt
871eaad1840d70a38b528d00e252e601?d=identicon&s=25 Xiu Ji (xiu)
on 2008-07-28 02:54
Hi,

I have spent almost my whole Sunday to fix the problem:

"no route found to match "/recipe/list" with {:method=>:get}", or
"no route found to match "/recipe" with {:method=>:get}"
depending on what I put into the browser.

I believe "http://localhost:3001/recipe/list should be the correct one.

I have tried everything and checked through my settings against the
tutorial many times. I still could Not solve the problem.

Could you please help where could go wrong?

Many Thanks!
40db9e75b3f5899258e3bdc0c9210154?d=identicon&s=25 Conrad Taylor (Guest)
on 2008-07-28 03:38
(Received via mailing list)
Hi, if you're using the default port,  it should be 3000 instead 3001.
 Thus, I would try using the following:
http://localhost:3000/recipe/list <http://localhost:3001/recipe/list>

Good luck,

-Conrad
871eaad1840d70a38b528d00e252e601?d=identicon&s=25 Xiu Ji (xiu)
on 2008-07-28 09:33
Thank you, Conrad!

After I started Mongrel, the application was loaded on port 3001.
Actually, my configuration steps were as the same as the 7 steps
provided in the orginal post of VolteFace at the top.

Any further information and advice on this could be very much
appreciated.

Please help and I really want a working installation to get me really
started with Rails.

Xiu
9a2a53db8e9b4476038c94a64b32833f?d=identicon&s=25 Ryan Bigg (ryan-bigg)
on 2008-07-28 09:37
(Received via mailing list)
Is the controller called recipes?

Then it should be localhost:3001/recipes
This topic is locked and can not be replied to.