Zlib compression issue

Hey guys.

  1. Can someone help me to fix this issue
    http://jira.codehaus.org/browse/JRUBY-5778:

This issue was already fixed, but it will be released in JRuby 1.6.5 and
I
don’t want to build from Master, because of possible regression bugs.

Is it possible to add a monkey patch somehow to fix that problem ?
Monkey
patch is the best way, but if it’s possible somehow to patch JRuby
classes,
this solution might work as well.

I found how that issue was fixed
https://github.com/jruby/jruby/commit/0f6a60e8f71ea978fd8557a9cfcce8278dce0caaby
Hiroshi N… Is there any workaround to patch JRuby classes
externally.

  1. As an alternative solution. How can I disable sending the Accept
    -encoding
    header. I use active-resource based library, and I think
    sending that header is a default behaviour.

Ok, I solved this problem. I used second solution. Waiting for 1.6.5
release.

2011/10/18 Pavel R. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs