"zero size buf in output"

Hello,

We have strange messages in our error.log - but everything works.
We tried to re-produce this in a testing-environment - but we couldn’t.

Thanks a lot
Sandy

2012/08/23 19:14:54 [alert] 17017#0: *1378690 zero size buf in output
t:0
r:0 f:0 00000000007DD3A0 00000000007DD3A0-00000000007DE6DB
0000000000000000
0-0 while sending to client, client: 1.2.3.4, server: seite.com,
request:
“GET /pathto/image.jpg HTTP/1.1”, upstream:
http://192.168.55.2:80/pathto/image.jpg”, host: “www.seite.com”,
referrer:
http://www.seite.com/

2012/08/23 19:40:02 [alert] 17017#0: *1383588 zero size buf in output
t:0
r:0 f:0 00000000007BB260 00000000007BB260-00000000007C5B75
0000000000000000
0-0 while sending to client, client: 1.2.3.4, server: seite.com,
request:
“GET /pathto/image.jpg HTTP/1.1”, upstream:
http://192.168.55.2:80/pathto/image.jpg”, host: “www.seite.com”,
referrer:
http://www.seite.com/

2012/08/23 19:49:47 [alert] 17016#0: *1385690 zero size buf in output
t:0
r:0 f:0 0000000000725010 0000000000725010-00000000007272B6
0000000000000000
0-0 while sending to client, client: 1.2.3.4, server: seite.com,
request:
“GET /pathto/image.jpg HTTP/1.1”, upstream:
http://192.168.55.2:80/pathto/image.jpg”, host: “www.seite.com”,
referrer:
http://www.seite.com/

2012/08/23 19:49:48 [alert] 17016#0: *1385689 zero size buf in output
t:0
r:0 f:0 0000000000725010 0000000000725010-000000000072A58C
0000000000000000
0-0 while sending to client, client: 1.2.3.4, server: seite.com,
request:
“GET /pathto/image.jpg HTTP/1.1”, upstream:
http://192.168.55.2:80/pathto/image.jpg”, host: “www.seite.com”,
referrer:
http://www.seite.com/

2012/08/23 19:49:48 [alert] 17016#0: *1385685 zero size buf in output
t:0
r:0 f:0 0000000000847910 0000000000847910-0000000000851E0C
0000000000000000
0-0 while sending to client, client: 1.2.3.4, server: seite.com,
request:
“GET /pathto/image.jpg HTTP/1.1”, upstream:
http://192.168.55.2:80/pathto/image.jpg”, host: “www.seite.com”,
referrer:
http://www.seite.com/

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,230072,230072#msg-230072

On Thursday 23 August 2012 23:58:01 double wrote:

Hello,

We have strange messages in our error.log - but everything works.
We tried to re-produce this in a testing-environment - but we couldn’t.
[…]

Do you use any 3rd-party modules?

wbr, Valentin V. Bartenev

nginx: 1.2.2
Modules: access, map, rewrite, proxy

configure arguments: --prefix=/usr/local/nginx --with-pcre
–without-http_charset_module --without-http_gzip_module
–without-http_ssi_module --without-http_userid_module
–without-http_autoindex_module --without-http_geo_module
–without-http_split_clients_module --without-http_referer_module
–without-http_uwsgi_module --without-http_scgi_module
–without-http_memcached_module --without-http_empty_gif_module
–without-http_browser_module --without-http_upstream_ip_hash_module
–without-mail_pop3_module --without-mail_imap_module
–without-mail_smtp_module --without-http_fastcgi_module

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,230072,230098#msg-230098

Same problem here

nginx -V

nginx version: nginx/1.2.3
configure arguments: --prefix=/usr/local/etc/nginx --with-cc-opt=’-I
/usr/local/include’ --with-ld-opt=’-L /usr/local/lib’
–conf-path=/usr/local/etc/nginx/nginx.conf
–sbin-path=/usr/local/sbin/nginx --pid-path=/var/run/nginx.pid
–error-log-path=/var/log/nginx-error.log --user=www --group=www
–with-file-aio --with-ipv6
–http-client-body-temp-path=/var/tmp/nginx/client_body_temp
–http-fastcgi-temp-path=/var/tmp/nginx/fastcgi_temp
–http-proxy-temp-path=/var/tmp/nginx/proxy_temp
–http-scgi-temp-path=/var/tmp/nginx/scgi_temp
–http-uwsgi-temp-path=/var/tmp/nginx/uwsgi_temp
–http-log-path=/var/log/nginx-access.log
–add-module=/usr/ports/www/nginx/work/ngx_http_gunzip_filter_module-0.4
–with-http_stub_status_module
–add-module=/usr/ports/www/nginx/work/nginx_upstream_hash-0.3.1
–with-pcre

uname -a

FreeBSD hostname 7.4-RELEASE-p9 FreeBSD 7.4-RELEASE-p9 #0: Mon Jun 11
19:47:58 UTC 2012
[email protected]:/usr/obj/usr/src/sys/GENERIC amd64
2012/09/13 15:38:03 [alert] 59568#0: *4954010 zero size buf in output
t:0
r:0 f:0 0000000814EE2000 0000000814EE2000-0000000814EE4000
0000000000000000
0-0 while sending to client, client: 90.133.66.18, server: hostname.ru,
request: “GET
/web/upload/forall/js/jquery-1.4.2_nyroModal-1.6.2_validate_capslock_jquery-ui-1.8.4.custom.min.js
HTTP/1.1”, upstream:
http://ip:80/web/upload/forall/js/jquery-1.4.2_nyroModal-1.6.2_validate_capslock_jquery-ui-1.8.4.custom.min.js”,
host: “delamour-ufa.ru
2012/09/13 16:05:32 [alert] 59567#0: *5305581 zero size buf in output
t:0
r:0 f:0 0000000800F3A000 0000000800F3A000-0000000800F3B000
0000000000000000
0-0 while sending to client, client: 92.243.167.145, server:
hostname.ru,
request: “GET /web/static/js/120907/jquery.admin.plugins.min.js
HTTP/1.1”,
upstream:
http://ip2:80/web/static/js/120907/jquery.admin.plugins.min.js”,
host: “landlifes.hostname.ru”, referrer:
http://landlifes.storeland.ru/admin/orders

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,230072,230696#msg-230696

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs