ZenTest 4.9.2 Released

ZenTest version 4.9.2 has been released!

ZenTest provides 4 different tools: zentest, unit_diff, autotest, and
multiruby.

zentest scans your target and unit-test code and writes your missing
code based on simple naming rules, enabling XP at a much quicker pace.
zentest only works with Ruby and Minitest or Test::Unit. There is
enough evidence to show that this is still proving useful to users, so
it stays.

unit_diff is a command-line filter to diff expected results from
actual results and allow you to quickly see exactly what is wrong.
Do note that minitest 2.2+ provides an enhanced assert_equal obviating
the need for unit_diff

autotest is a continous testing facility meant to be used during
development. As soon as you save a file, autotest will run the
corresponding dependent tests.

multiruby runs anything you want on multiple versions of ruby. Great
for compatibility checking! Use multiruby_setup to manage your
installed versions.

Changes:

4.9.2 / 2013-05-29

  • 2 minor enhancements:

    • Added autotest-suffix description to readme. (blowmage)
    • zentest now outputs test classes for minitest 5

Ryan D. wrote in post #1110616:

ZenTest version 4.9.2 has been released!

I get this :
Invalid gemspec in
[C:/Ruby193/lib/ruby/gems/1.9.1/specifications/ZenTest-4.9.2.gemspec]:
Illformed requirement ["< 2.1, >= 1.8"]

My environment is;

RUBYGEMS VERSION: 1.8.24
RUBY VERSION: 1.9.3 (2013-05-15 patchlevel 429) [i386-mingw32]
INSTALLATION DIRECTORY: C:/Ruby193/lib/ruby/gems/1.9.1
RUBY EXECUTABLE: C:/Ruby193/bin/ruby.exe
EXECUTABLE DIRECTORY: C:/Ruby193/bin
RUBYGEMS PLATFORMS:
ruby
x86-mingw32
GEM PATHS:
C:/Ruby193/lib/ruby/gems/1.9.1
C:/Users/Michel/.gem/ruby/1.9.1
GEM CONFIGURATION:
:update_sources => true
:verbose => true
:benchmark => false
:backtrace => false
:bulk_threshold => 1000
“gem” => “–no-ri --no-rdoc”
REMOTE SOURCES:
http://rubygems.org/

Michel D. wrote in post #1110661:

Ryan D. wrote in post #1110616:

ZenTest version 4.9.2 has been released!

I get this :
Invalid gemspec in
[C:/Ruby193/lib/ruby/gems/1.9.1/specifications/ZenTest-4.9.2.gemspec]:
Illformed requirement ["< 2.1, >= 1.8"]

My environment is;

Updated rubygems to 2.0.3 => same thing.

Michel D. wrote in post #1110699:

Michel D. wrote in post #1110661:

Ryan D. wrote in post #1110616:

ZenTest version 4.9.2 has been released!

I get this :
Invalid gemspec in
[C:/Ruby193/lib/ruby/gems/1.9.1/specifications/ZenTest-4.9.2.gemspec]:
Illformed requirement ["< 2.1, >= 1.8"]

My environment is;

Updated rubygems to 2.0.3 => same thing.

Day after. Did not change anything. Bug disappeared. Closed.

Jason H. [email protected] wrote:

My environment is;

Updated rubygems to 2.0.3 => same thing.

Day after. Did not change anything. Bug disappeared. Closed.

I still see this error with gems 1.8.24 on a c9.io online IDE instance.

The steps are really pretty clear. Go look at the github issues list as
well. It’s very well spelt out.

Michel D. wrote in post #1110927:

Michel D. wrote in post #1110699:

Michel D. wrote in post #1110661:

Ryan D. wrote in post #1110616:

ZenTest version 4.9.2 has been released!

I get this :
Invalid gemspec in
[C:/Ruby193/lib/ruby/gems/1.9.1/specifications/ZenTest-4.9.2.gemspec]:
Illformed requirement ["< 2.1, >= 1.8"]

My environment is;

Updated rubygems to 2.0.3 => same thing.

Day after. Did not change anything. Bug disappeared. Closed.

I still see this error with gems 1.8.24 on a c9.io online IDE instance.

I’d like to have ZenTest (also, RubyInline), but RubyGems is now version
2.1.2 and ZenTest needs RubyGems to be lower than 2.1.

Is ZenTest going to be updated too?

Thank you!
hewhocomes

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs